Long load times (Animal Crossing New Leaf: Welcome Amiibo)

Issue:
Loading screens for the game are very slow and will often show “Speed: 0% / 100% Game: 0 FPS Frame: nan ms” with a fully black screen most of the time. Gameplay is almost always fine but every loading screen takes a long time every time, up to a minute or two sometimes.
Just transferred my game data yesterday to Welcome Amiibo version from standard New Leaf, which is when the issue started. Game crashed immediately after I transferred my data and froze during gameplay within the last few hours. Thank you for the help

System Information

  • Operating System: macOS High Sierra
  • CPU: 1.6 GHz Intel Core i5
  • GPU: Intel HD Graphics 6000 1536 MB
  • Citra Version (found in title bar): New Citra XL
  • Game: Animal Crossing - New Leaf - Welcome Amiibo
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log copy.txt (64.8 KB)

System Information for Support

Client Version                                Canary 1628 HEAD-7025f72
OpenGL Vendor                                 Intel Inc.
OpenGL Renderer                               Intel(R) HD Graphics 6000
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You are using open source system files for Mii data. This will appear as your Mii having broken graphics, but will not affect the stability of the game. In order to resolve this, please refer to our guide on dumping system files. https://citra-emu.org/wiki/dumping-system-archives-and-the-shared-fonts-from-a-3ds-console/

Try turn off Disk Shader Cache in the graphics options in Citra. It has issues for some users with some games at the moment.

Disk Shader Cache is not an option to turn on for me.


It is shaded out so I cannot turn it off, since it is not on for me

Hm, strange since in your log it says it’s on Utility_UseDiskShaderCache: true

Perhaps go to ~/.config/citra-emu/ and edit qt-config yourself and set it to false instead.

Looked through the file and it says false already
Screen Shot 2020-04-07 at 2.12.48 PM

i have the same issue now , is there a fix to this ?

so i tried with some of the past builds (1450) and it actually has less long loading times ( around 5 secs from 20 secs) , so it probably something about those updates ?

Since I don’t have a mac I cannot test or investigate when these issues started to happen unfortunately. See if you can bisect the issue by testing older builds: https://github.com/citra-emu/citra-nightly/releases?after=nightly-1466 (just change the number at the end to jump instantly to much older builds so you won’t have to press next constantly).

Choose a starting point e.g 1200, if 1200 works then it’s between 1465 and 1200 so you pick a build in the middle e.g 1332 and if 1332 also works then it’s between 1465 and 1332 but if 1332 does not work then it’s between 1332 and 1200. Repeat the process until you end up with two builds where one is working and the other is not.

1 Like

Same issue here, on windows 7

Edit: I don’t think that one exact update is the problem, loading times get progressively worse. 1400 loading times are almost instant, 1450 is slow but bearable, and the newest update is several minutes of wait.

1 Like

Found it - version 1422 loading times are 3-4 seconds for me, but version 1423 is around 20 seconds.

2 Likes

Tried 1422 and it’s working a lot better now, significantly faster load times. Thank you all for your help :cowboy_hat_face:

3 Likes

Yeah, but like, can we make a new update work just as well?

Hi I have exactly the same problem with the loads and just like you I had just transferred my NL part to WA the loads are much longer and it’s very annoying. has anyone already solved the problem?
I specify that on my side I don’t have a mac but a windows

Above solution worked for me. I tried using Nightly 1422 (https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1422) and load times are a lot faster than most recent update. User Bevo above is also on Windows are found load times were slow starting at Nightly version 1423. I’m not support but Citra support users helped solve the issue for my game so I’d recommend that

2 Likes

What are we supposed to do with the file we are downloading here?

1 Like

Like where do we put the older builds?

What I did is downloaded the 1422 version of nightly, then in that file, there is a citra-qt application with the citra logo, so open up that version of citra and play there. I saved a shortcut to that instead of the new version so that I open the correct one

Hey, win7 user here, I started playing ACNL this week, and it was fine. switched to Welcome amiibo and experiencing 30 sec longer load times.

I’m about to try the 1422 version but i wanted to confirm it happened to me as well.

Edit: yea, 1422 has drastically faster load times. thanks to other users for the help.

I had some issues with loading times on pokemon games with this new update. Disabling the new 3ds mode did the trick for me. Maybe thats the problem on AC as well?
Edit: there are some problems with loading and transitions in this new update, can someone test this and see if it makes a difference on other games?