Low fps and graphic issues while playing in OpenGL in AMD

I am trying to run Yuzu 295 in OpenGL. I have AMD R5 M330 + Intel HD Graphics 620 GPU with 16GB RAM. Since Isle of Armor fails while being played using Vulkan, I am trying to run it in OpenGL. However, when I am running the game I experience low fps + this graphic issue as well. Any way to fix this issue?

yuzu_log.txt (2.2 MB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

That log is incomplete, you need to open Yuzu and go to log directory, start the game move around and do a battle, turn the game off and close Yuzu and post the log again, don’t start Yuzu again it will reset the log.

System Information for Support

Client Version                                yuzu 295             . HEAD-mainline-636-2402-geecf58ec6
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | AVX2 | FMA
Graphics API                                  OpenGL 4.3.1
Graphics Renderer                             AMD Radeon (TM) R5 M330
GPU Driver Version                            20.11.2 27.20.14501.18003
Docked Mode                                   [ ]
Use Async GPU                                 [x]
BCAT Backend                                  boxcat
GPU Emulation Accuracy Level                  High

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • You have Boxcat (BCAT) enabled. Some games might not work when this is enabled. Please disable and try again if you are experiencing issues with games.

I have re-uploaded the log file.

Amd has problems with OpenGL.

Run this game in Vulkan with AMD GPUs.

I tried running the game in Vulkan. However, when I reach Isle of Armor anywhere, the game gets stuck. Even when I restart it, the game will be stuck. Then, I switch to OpenGL Yuzu 295 to proceed the game.

Unfortunately, OpenGL is not known to not be good on AMD, don’t know what if you can do anything about that