Low fps and laging in monster hunter 4

Issue:

citra runs monster hunter 4 between 40 and 70 percent of the equipment capacity making the game lag despite having a decent frame rate. In addition, the xBRZ freescale filter must be optimized since it is seen with light beams (glitch with xBRZ freescale). It was played at 960p with an MX 330.

System Information

  • Operating System: windows 10 20h2
  • CPU: i5 1035g1 with unlock to 3.6 but without over clock
  • GPU: MX330 driver 7 january 2021
  • Citra Version (found in title bar): 1678
  • Game: Monster Hunter 4
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (16.2 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1678 HEAD-e33677b
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-1035G1 CPU @ 1.00GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce MX330/PCIe/SSE2
GPU Driver Version                            461.09
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

MH4U needs a cheat code to turn off the 3D effect to boost performance and make the image clear.

https://github.com/citra-emu/citra-games-wiki/wiki/Monster-Hunter-4-Ultimate

Make sure you have v1.1 game update installed to use the code. More info here:

Those temperatures aren’t healthy but I guess you are already aware :stuck_out_tongue:

I have tried 1 the

(Disable Stereoscopic 3D)

610572CC 00000000
B10572CC 00000000
00006BA8 011F036E
D2000000 00000000

2 (30 FPS Cap)

61057194 00000000
B1057194 00000000
00000030 41F00000
D2000000 00000000

but I have only noticed improvement with visual glitch, on the other hand, forcing it to 30fps has not improved the problem with sound lag :thinking:. I hope it is not the rom that is failing.

On the other hand I have an RGB base with five fans, I hope what is failing is not a problem with the driver temperatures.

Sound is tied to emulation speed, so if you are not reaching 100% speed it won’t sound good.

You might need to decrease the resolution to 3x as well.

The codes only work with v1.1 so make sure that is installed:

image

If you don’t have it, here is a guide how to dump it:

install version 1.1 and it remains the same, as you suggest I should have lowered the resolution to x2 for it to work perfectly.

It worked, thanks.

1 Like