Low fps both on citra nightly and canary

Issue:
Enter a description of your issue here, in full detail.
Extremely low fps tried on both citra nightly and canary. First time this happened.

System Information

  • Operating System: WIN10
  • CPU: 2.70GHz Intel Core i7
  • GPU: Intel R Graphics 620
  • Citra Version (found in title bar): tried on both canary and nightly
  • Game: Story of Seasons Trio Towns
  • Screenshot of Issue (include the full Citra window including titlebar):
    citra_log.txt (183.4 KB)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the [citra_log.txt|attachment]
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1640 HEAD-4f8f8e8
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               AMD Radeon HD 8500M
OpenGL Version                                3.3.1
GPU Driver Version                            20.2.2 26.20.15019.19000
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

The coretiming 2.0 change caused a regression unfortunately so try Nightly 1422: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1422

tried nightly 1422, unfortunately this didn’t worked for me.

I see, you could try configure Switchable Graphics in Radeon Settings to use your Intel GPU instead since AMD GPUs have poor OpenGL performance on Windows :confused:

I’m not sure if this game is demanding though.

Thanks! This finally worked for me. :slight_smile: Albeit the switchable graphics tab in radeon is missing since their last update so I decided to disable AMD in the device manager. Made my laptop became faster too!

1 Like