Low FPS on LOZ: Link Between Worlds

Issue:
While I haven’t spotted any other glitches, the FPS for “The Legend of Zelda: Link Between Worlds” is extremely low. The game usually runs at an average of 30 or 40%, and it has gone as low as 14%. Highest FPS while playing has been around 60%, but only in specific areas if I’m lucky. In addition, the FPS can change wildly as I’m moving around. The only time the FPS is normal is when the screen turns black.

System Information

Diagnostic Log
citra_log.txt (11.8 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1678 HEAD-e33677b
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon (TM) R7 M445
GPU Driver Version                            19.50.26 26.20.15026.1
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

Try turn off Hardware Shader, it might boost speed on Radeon GPUs.

Update the drivers as well, latest is 21.1.1: https://www.amd.com/en/support/graphics/amd-radeon-r7-series/amd-radeon-r7-400-series/amd-radeon-r7-m445

You can also attempt to run on your iGPU instead, Intel’s drivers for OpenGL on Windows are a bit better than AMD’s. Make sure drivers are updated as well: https://downloadcenter.intel.com/download/30148/Intel-Graphics-Windows-10-DCH-Drivers.

If you are unable to install 9168 right away, update to 6373 first:
Download win64_25.20.100.6373.zip from https://downloadcenter.intel.com/download/28289/Intel-Graphics-Driver-for-Windows-10
direct link: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip
then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Sorry, it’s been a while.

I tried updating my Radeon GPU, but it did not help in the slightest. Also tried the Intel one, which did her, but the performance is about 50+ % now (sometimes it climbs to about sixty, but only for a few moments). I have no idea how to turn off the hardware shader.

It is in the advanced graphics settings in Citra configuration.

OK, FPS up over 80% now. I think that’s pretty good. No changes in the quality of the game either. Thanks.

1 Like