Low FPS on Pokemon Games

Issue:
When entering a battle on pokemon, the game always stutters due to low FPS.

System Information

  • Operating System: Windows 10 Pro
  • CPU: Intel® Core™ i708700 CPU @ 3.20 GHz
  • GPU: GeForce RTX 2060
  • Citra Version:
  • Game: Citra Canary 1644
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (1.0 MB)

System Information for Support

Client Version                                Canary 1644 HEAD-f89266a
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce RTX 2060/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            445.75
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Issue :
Game Crashes when Accurate Multiplicatopm is enabled.

Diagnostic Log
citra_log.txt (277.6 KB)

System Information for Support

Client Version                                Canary 1644 HEAD-f89266a
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce RTX 2060/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            445.75
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

The coretiming 2.0 change caused a regression unfortunately so try Nightly 1422: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1422

Next:

  1. File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Accurate Multiplication shouldn’t crash you anymore either.

1 Like