Low FPS on Pokemon Sun

I’m trying to play pokemon sun and moon on citra but I can only get 14 FPS (50% speed). I saw some post and they said that you need good cpu but I think mine is pretty good. So I don’t know what’s wrong. Can someone please help me?

System Information

  • Operating System: Windows 10
  • CPU: i7-6700HQ 2.60GHz
  • GPU: Nvidia GTX 960M
  • Citra Version (found in title bar): Nightly Build - bae3799
  • Game: Pokemon Sun

Make sure that you aren’t running any GL hooks (like Fraps, MSI Afterburner, Dxtory) with Citra.

Check if V-Sync is off and Limit Framerate is on. Make sure that the internal resolution is about the size of your display, because higher resolution = lower frames. Use 4x for 1366x768 and 5x for 1920x1080. Don’t go any higher than 5x.

There’s a another performance boosting step in Sun / Moon, but I think that the rules of these forums don’t allow me to put up the fix. (It’s the hex edit patch, if someone knows.)

The main problem is your CPUs single-core performance. It only scores 1803, which isn’t much.

1 Like

Yes my limit framerate is on my V-sync is off and I don’t have any Fraps or something. My Graphics are on native as Well. I tried with hex build (more i’m not going to say on this forum) but it’s Still the Same tnx anyway.

Don’t use any custom builds here please.

Also, I was not talking about a Citra build that does the hex edit, but a hex code that you can apply to the ROM itself.

oh… Sorry waw this is akward. Didn’t mean to sorry.

Here are the specs for my computer:
Lenovo Y50 i7-4720HQ GTX860M
SSD 2441

When I use Citra for Sun, the Rom always runs so slowly, that it is not even worth playing the games. It seems like I have more than enough RAM and the CPU is barely taxed at all, so are there any tips on improving the performance? Thanks!

Citra is still in very early stages of development.

Games usually don’t run at full speed even on the best computers.

Laptop CPUs usually have worse single core performance than desktop CPUs.

1 Like

I am seeing similar and mentioned this in my game compatibility note for Pokemon Moon.
I also have that patch mentioned with no increased performance, so I think it is more aesthetic than anything.
I have a R3 1200 OC’d to 3.8GHz, 16GB of DDR4 ram OC’d to 2666MHz, and a GTX 1050 slightly overclocked as well using XOC. Even disabling the GPU overclock by closing XOC yields no difference.
It actually looks like Citra has yet to leverage multi core performance. I am not even taxing my CPU, as Citra alone pools ~30-50% utilization of my CPU, leaving more than enough horsepower to spare.
Native internal resolution results in an average of 20 FPS, and any other resolution drops it down to a 15 FPS average regardless.
I think once Citra starts taking advantage of multicore CPUs, it might actually increase performance.
V-sync and limit FPS have no effect on my build.

I have the same issues with my AMD Athlon 870k quad core 3.9GHz and 8GB ram and a R7 360 series. I have seen videos of people running it with 60 FPS almost constantly but haven’t been able to recreate this.

You can’t trust YouTube when it comes to Citra.

The videos could be very well sped up.

Again, as I’ve said, Citra is still in it’s early stages of development and isn’t well optimized.

I found a good way to increase FPS. First of all, make sure your screen is not using any custom scaling, as the graphics card has to render more if a custom scaling factor is used. So, use a default scaling factor. Next, make sure that any battery-saving options are turned off in your graphics card control panel (I can’t tell you how to do this as I have an Intel HD Graphics 520, while you are using a NVIDIA GPU). Last, turn off any night light or anything else that you think will cause your graphics card to do more work than it should. In theory, the less amount of tasks your graphics card has to do, the better your fps will be. Before doing all this, I only got around 14 fps (about 50%). Now I’m at 70% speed outside, and 100% inside a building. Good Luck! Oh! I almost forgot! Make sure that you are using Citra’s lowest resolution (Native), as a larger resolution might cause a bit of a drop on your fps.

The internal resolution changing shouldn’t affect anything in terms of FPS (maybe except if you’re using 10x internal resolution), because Citra almost doesn’t use the GPU. It’s the CPU that causes low frames.

1 Like

Weird…The FPS immediately increased after I changed the resolution and disabled the night light (which makes your screen yellow, like blue light filter). The thing is, I was searching for ways to boost my performance on Citra, because my brother’s laptop, which has the same specs as mine does, had way better fps than mine. I thought of why that happened, and I tried copying his screen settings (turning custom scaling off, and turning night light off, too). Citra was already at Native resolution, but to my surprise, after replicating my brother’s settings, Citra was running way faster than before. If you were wondering, I’m using a Spectre Laptop (the old one) with an Intel i7 6500u (2.50GHz), along with an Intel graphics 520.

Can you show me your settings to make citra faster?

Here are screenshots of my settings: https://imgur.com/a/BfmnP

I have done lots of things to make citra run faster, but only the starting screen has good fps. Everythings else has up to 18 fps and i cant play my games. I’m more interested in pokemon, but I don’t care about what game it is. If there is any way to make it run faster then please let me know.

That’s normal. If you don’t have a high end CPU that has high single core performance, that’s the performance you should get.

My PC can’t with Pokémon Moon neither T.T
I have 20-25 fps outside buildings. My computer is a:
i7 [email protected] 4.4Ghz
GTX 1060
16Gb Ram
If someone can help me to improve my performance It will be helpfull.
Thanks and sorry for my english. xDDD

There’s not much that you can do that’s not already said in this topic. @GDhex12’s post has pretty much everything you need to know really.

All those who are saying “I don’t have higher Frame Rates, although i have beefy machine”, you aren’t supposed to! Most people do not have enough single core performance in their CPUs. Please read @GDhex12 s replies. And citra doesn’t use your dGPU. You can check this using task manager if you run Win10 or there are plenty of tools out there if you don’t. So all we have to do is, just wait till they release a version that takes use of dGPU and /or multiple threads. Fingers crossed! :slight_smile: