Low FPS on Yuzu's Buffer Cache Rewrite builds

Hello again,

For some reason I’m having lower FPS on Yuzu’s latest builds that include the “Buffer Cache Rewrite” feature. I’ve read that this gives a performance boost (on Super Mario Odyssey for example), but this isn’t the case for me.

On Yuzu EA-1298 (before the buffer update) I’m getting 60fps most of the time, with occasional frame drops to 50fps, which is great and it feels very fluid:
SMO Yuzu EA-1298

And on Yuzu EA-1357 (same with 1350 and 1356) I’m getting between 55-60fps with frame drops to 39-40fps, these slowdowns are notorious at the T-Rex part and when Mario becomes 8-bit:
SMO Yuzu EA-1357

Sorry about the video’s quality but the screen capture software dropped the framerate and the purpose is just to show the FPS at the upper-right corner.

These are my specs:

  • Intel Core i5-7500 3.4GHZ
  • 16GB RAM DDR4 2133MHZ
  • PNY GT 1030 DDR5 2GB

Yuzu.exe is running as Administrator. I’ve attached screenshots for Yuzu settings, Nvidia Control Panel Settings and SMO Mods (for both Yuzu EA 1298 and 1357), and Yuzu’s log for 1357 (which I’ve trimmed because it exceded the 4096kb upload limit).

Thanks in advance

System Information for Support

Client Version                                yuzu Early Access 1357 HEAD-d554dbd63
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz | AVX2 | FMA
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             GeForce GT 1030/PCIe/SSE2
GPU Driver Version                            460.89
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                yuzu Early Access 1357 HEAD-d554dbd63
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz | AVX2 | FMA
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             GeForce GT 1030/PCIe/SSE2
GPU Driver Version                            460.89
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Most games now perform faster with high GPU accuracy instead of normal.

1 Like

System Information for Support

Client Version                                yuzu Early Access 1357 HEAD-d554dbd63
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz | AVX2 | FMA
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             GeForce GT 1030/PCIe/SSE2
GPU Driver Version                            460.89
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Ok I’ll give a try and report back…

I changed GPU accuracy from “Normal” to “High” and now it runs even slower, 40-47fps

Revert anisotropic to default, disable asynchronous shaders if assembly shaders is enabled, and remove all mods, except disable dynamic resolution, use that one.

1 Like

I applied the suggested settings but performance is still inferior to Yuzu EA-1298

Can you post me a fresh log?

Sure, here’s the log for Yuzu EA-1375 where frame drops persist,. I upgraded to a i5-7500, still getting great performance on EA-1298

yuzu_log.txt (1.1 MB)

System Information for Support

Client Version                                yuzu Early Access 1375 HEAD-0d6aaa0f7
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7500 CPU @ 3.40GHz | AVX2 | FMA
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             GeForce GT 1030/PCIe/SSE2
GPU Driver Version                            460.89
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

This may be completely irrelevant, but can you try with the latest 461 driver? Just to discard that.
Also, check that you are not forcing settings in per game profiles.

1 Like

I updated to 461 driver but same result. As a last resort (I was about to give up) I deleted the shader cache file, and it worked!!! I vaguely remember that sometime ago when there was an update on Early Access somebody said that we had to delete and rebuild the shader cache for the new release. Now I’m getting 60fps (most of the time) on SMO without any mod.

Thanks for your assistance @GoldenX86

Best regards