Low FPS Pokemon Gates to Infinity

Tried some recommended settings from other threads and videos. Fixed the screen from freezing by unchecking ‘enable hardware renderer’. Unable to change internal resolution.

System Information

  • Operating System: Windows 10
  • CPU: * Intel Core i3-1005G1 1.20 - 3.4GHz
  • GPU: Intel UHD Graphics 620
  • Citra Version (found in title bar): Citra Nightly 1683
  • Game: Pokemon Mystery Dungeon Gates to Infinity
  • Screenshot of Issue (include the full Citra window including titlebar): image

Log:
citra_log.txt.old.txt (21.8 KB)

System Information for Support

Client Version                                Nightly 1683 HEAD-2461f67
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-1005G1 CPU @ 1.20GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics
GPU Driver Version                            26.20.100.8141
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Two days with no answers. Hoping a new reply on the thread will get attention.

Be patient, we will eventually get to you.

The reason you can’t change resolution when you turn off Hardware Renderer is because it is not possible to change resolution on the Software Renderer (which is turned on automatically when you turn off Hardware Renderer).

But software renderer is very slow, pretty much everyone would get 1fps.

You should update the drivers: https://downloadcenter.intel.com/download/30148/Intel-Graphics-Windows-10-DCH-Drivers

My apologies. Didn’t realize that you were still monitoring and on top of it and was worried about having my post buried. Which I see is untrue. I realize that definitely came off as rude and unappreciative and I’m sorry for that.
Updated the driver with the link you posted and restarted my laptop to try again- speed is still under 15% all the time (usually under 10%) with a FPS around or under 5.

1 Like

If you still have Hardware Renderer and Hardware Shaders disabled, you should re-enable both. If it ends up freezing again, upload another log file here so we can take a look at it at what might be happening.

That seems to have fixed it. It had problems with those enabled before and seemed to not freeze when I turned them off. Looks like it was a mixture of the driver update and enabling those settings again. Thanks! I’ll let you know if it freezes again.

1 Like