Low speed (50%)

Issue:
Yesterday, I played my game “Pokemon saphir” without any problem for 5h.

And today, the speed of the game is very low 50%. I change configuration nothing change.

I think the problem comes from here : Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:DebugHandler:535: API PERFORMANCE 131218: Program/shader state performance warning: Vertex shader in program 9 is being recompiled based on GL state.

[ 82.452318] Service core/hle/service/service.cpp:ReportUnimplementedFunction:166: unknown / unimplemented function ‘SetProbeResponseParam’: port=‘nwm::UDS’ cmd_buf={[0]=0x210080, [1]=0x321f00, [2]=0x40000}

I installed all the new versions of citra, still not working.

System Information
I have a good computer, it’s not the problem. The game was working well.
citra_log.txt (151.8 KB)

https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1376 HEAD-8339d29
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

I Enabled Accurate Multiplication, still the same problems. 15 fps citra_log.txt (52.9 KB)

System Information for Support

Client Version                                Canary 1376 HEAD-8339d29
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

System Information for Support

Client Version                                Canary 1376 HEAD-8339d29
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Same with the Nightly Citra
citra_log.txt (36.7 KB)

[ 82.452318] Service core/hle/service/service.cpp:ReportUnimplementedFunction:166: unknown / unimplemented function ‘SetProbeResponseParam’: port=‘nwm::UDS’ cmd_buf={[0]=0x210080, [1]=0x321f00, [2]=0x40000}

System Information for Support

Client Version                                Nightly 1285 HEAD-c81a96b
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                Nightly 1285 HEAD-c81a96b
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                Canary 1376 HEAD-8339d29
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Check if you have v-sync forced to ‘On’ on Nvidia’s control panel, or any other 3rd-party tool like msi afterburner that may limit your framerate and disable them.

Turn off Battery Boost in GeForce Experience. Use a high-performance power plan in Windows as well as in Nvidia Control Panel(set to Prefer maximum performance under Power management mode).

It happens the same to me too