Low speeds despite having a decent PC

Issue:
Despite having a decent GPU and CPU, I’m having really bad slow downs in Luigi’s Mansion 3D (and a few other 3DS titles). I seem to get about 57% in LM3D.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-3470 @ 3.20GHz
  • GPU: AMD Radeon 7800 Series
  • Citra Version: Canary 1215
  • Game: Luigi’s Mansion
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (4.4 KB)

System Information for Support

Enable CPU JIT                                [ ]
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [ ]
Enable Shader JIT                             [x]
Enable Vsync                                  [ ]
LLE Audio Emulation Enabled                   [ ]
Use GDB Stub                                  [ ]
System Region                                 -1
OpenGL Version                                null
OpenGL Vendor                                 null
OpenGL Renderer                               null

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Enable CPU JIT                                [ ]
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [ ]
Enable Shader JIT                             [x]
Enable Vsync                                  [ ]
LLE Audio Emulation Enabled                   [ ]
Use GDB Stub                                  [ ]
System Region                                 -1
OpenGL Version                                null
OpenGL Vendor                                 null
OpenGL Renderer                               null

I did not find anything wrong in your log file. Please wait for a moderator to assist.

You have hardware shader disabled. Unless your GPU is incompatible with this (AMD is known to be poor in it’s support of OGL), you should attempt to enable it, not using it will cause a significant degradation in performance.

Oddly enough, hardware shaders worsen the performance, but this is most likely due to what you mentioned about AMD’s poor OpenGL support.

The good news, however, is that I did manage to get much better performance (almost a consistent 100% speed) although I do still experience dips here and there. It seems including 3DS system files and fonts fixes this issue (which I must have glazed over when reading the wiki page). As for the framedrops, perhaps those could be due to the unfinished state of Citra and will be fixed down the road?