Mac Citra Bug on MacosX

Issue:

Hello,
I have a problem concerning the pokemon games : when I launch the game for the first time, there is no problem, on the other hand the second time, Citra crashes and marks me : Citra quit unexpectedly here is the log

System Information

  • Operating System: Mac OS X
  • CPU: ?
  • GPU: ?
  • Citra Version (found in title bar): Citra Nightly 1659
  • Game: Pokemon Sun, Pokemon Ultra-Sun, Pokemon X, Pokemon Y…
  • Screenshot of Issue (include the full Citra window including titlebar):


citra_log.txt (5.4 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Try this older build: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1587 there is a change on the newer builds that macOS doesn’t like.

It doesn’t work too what should I do ?

It looks like you accidentally reopened Citra before uploading the log. The log gets cleared every time you open Citra. Have the log folder open in the background first before closing Citra then immediately upload a new log.

There is the log
THE LOG.txt (6.4 KB)

System Information for Support

Client Version                                Nightly 1587 HEAD-bd7ee8c
Operating System                              macOS 10.15
CPU                                           Intel(R) Core(TM) i5-8500 CPU @ 3.00GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Try disabling Hardware Shaders in Citra>Preferences>Graphics>Advanced Tab.

This time, it doesn’t worked too but a loading bar appeared there is the new logcitra_log.txt (13.7 KB)

System Information for Support

Client Version                                Nightly 1659 HEAD-3f13e1c
Operating System                              macOS 10.15
CPU                                           Intel(R) Core(TM) i5-8500 CPU @ 3.00GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             AMD Radeon Pro 560X OpenGL Engine
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

How to disable them ? (on mac and without opening any game)

Delete the cheats folder at ~/.config/citra-emu

I deleted the cheat folder but I didn’t worked there is the new log… :pensive:
citra_log.txt (12.7 KB)

System Information for Support

Client Version                                Nightly 1659 HEAD-3f13e1c
Operating System                              macOS 10.15
CPU                                           Intel(R) Core(TM) i5-8500 CPU @ 3.00GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             AMD Radeon Pro 560X OpenGL Engine
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

What should I do ? pls help me

Enable Hardware Renderer but turn off Hardware Shader.