[Mac] PS4 Controller won't do anything in-game, no inputs or responses?

On my Mac, the PS4 Controller will not work on Citra Canary:
I’ve followed Simply Austin’s tutorial of him installing Citra & running it fine, I followed all of the equivalent steps that’ll apply to a Mac.

I’ve edited the “qt-config.ini” with different Control settings to enter in. Nothing. I tried separately connecting it Bluetooth & editing the Emulation inputs for the controller, still nothing. Yes I connected it & am using Joystick Mapper, & yes I’ve completely enabled my bindings for it, & yes it was checked when I had previously tried these methods.

Mac OS Mojave

  • Operating System: Mojave / Apple Computer - MacBook Pro 13inch 2016
  • Citra Version (found in title bar): Citra Canary 1118
  • Game: Animal Crossing: New Leaf
  • Screenshot of Issue (include the full Citra window including titlebar): None available.

Screenshot of my computer such as CPU & GPU.

Diagnostic Log
This is nothing to do with a game, nothing will receive inputs from the PS4 Controller, it will register inputs in the settings, but nothing incase will receive any type of input.

Here is the log.

No Sound - This is a video summarizing the problems but showing some of its capabilities. @bio3c

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

This is the log - here. It doesn’t tell me anything that says why this isn’t working.

i can see that your DS4 is being recognized as an audio device by citra, maybe that is interfering somehow!? do you have steam open? if so, disable DS4 support on the big picture mode.

edit: does different bluetooth pairing mode appear for you DS4?

I can successfully connect it via Bluetooth as here is my Mac with it on & connected. Just nothing like before.

does it appear like in this thread? does it let you choose how to pair the DS4?

I had trouble to configure my DS4 when I recently started (like less than a week ago)

The thing is, I am on Windows and no bluetooth so this MAY not the be the answer, I’m just gonna put what I remember doing when I finally made it works …

First, I found out that there is maybe more than one “qt-config.ini”, I am not sure of that information but verify in case its the case X)

Second, I remember going through ALOT of the config offer of this page ( you probably know what it is ) http://www.jannikvogel.de/scratchpad/citra-input-map/

and finally, I think the REAL thing that made my controller works was when I decide to bind them myself on the control page of Citra …

So yeah, all I know, no idea if that help in any way, but I guess this can’t hurt that I try at least XD

Have a nice … night ? day ? whatever ! :smiley:

Not really, for connecting it through Bluetooth, it pairs normal. But while it was paired via Bluetooth I connected it with the cord trying a different way & it seemed to reconnect. But when I tried the cord again (without bluetooth) it just blinked the orange light, & never showed signs of pairing.

does it work on other games? for instance, does with work here?

No it doesn’t show up on the HTML5 Gamepad Tester, not wired connection, not Bluetooth. Although it has the pulsing orange light on the controller when its plugged in wired.

any other games? perhaps small demo games available in the app store?

When the controller is connected via Bluetooth, it’ll work on the PCSX2 Emulator & Dolphin.

huh, dolphin uses SDL for gamepad and so does citra, but i think dolphin uses the native api on mac… maybe its a SDL issue, maybe related, that’s the only info i could find rn.

try to configure using this tool (if you haven’t tried already): http://www.generalarcade.com/gamepadtool/

Okay, I’ll use the tool you linked when I get free time. That won’t be for like until Monday almost, & if you want I can do a video & show you everything.

just one thing, iirc you need to first close citra if you want to manually edit the qt-config.ini file and then open citra for the changes to take any effect. the same goes for the sdl2 gamepad tool, either set the environment variables and/or paste the gamecontrollerdb.txt file on the citra folder (where citra-qt is located).