Majoras mask 3d low fps

Issue:
Why is my Majoras Mask 3D running so low
Almost everywhere in Majoras mask is 20-25 fps. I tried the unofficial bleeding edge build, it runs at 30 fps but it does not support mouse2joystick. My computer specs are fine since I can run Hyrule warriors at around 30 fps.

  • Operating System: Windows 10
  • CPU: Intel ® Core ™ i5-6200U CPU @ 2.30GHz 2.40GHz
  • GPU: AMD Radeon R5 M335
  • Citra Version (found in title bar):Citra Canary 1314
  • Game: Majoras mask 3d
  • Screenshot of Issue (include the full Citra window including titlebar):

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Try disabling ‘Enable Hardware Shader’. note that mouse2joystick has issues and it can reduce performance considerably.

I already disabled “Enable hardware Shader” if it was enabled it wouldn’t even run at 20 fps
I also tried it without mouse2joystick enable and it still runs at 20-25 fps

There isn’t much to change on citra to improve performance, try using your integrated GPU, it may perform better.

I already tried that it was worse, stuck at 20 fps

You can try canary-1041 it had a feature that uses multiples cores to improve performance when ‘Enable Hardware Shader’ is disabled.

Dumb question byt how do I download old versions of citra?

Ok that actually worked thanks

where find this unofficial bleeding edge build?

Citra “Canary” builds were previously called “Bleeding Edge” (3 or 4 years ago I think) , they are not unofficial but very much outdated. You can get both Canary and Nightly builds from the official download page either by manual download or by using the installer.

1 Like

thank you man(or woman)