Mario 3D Land 3D Graphics Won't show

Issue:
When I start Mario 3D Land, none of the 3D graphics/models load, only the UI and smoke from Mario’s feet show and just blue or black shows behind all of that

System Information

  • Operating System: Windows 10
  • CPU: @ 2.00GHz
  • GPU: Not sure
    Intel ® Core™ i3-6006U
  • Citra Version (found in title bar): Citra Canary 964
  • Game: Super Mario 3D Land

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

follow the bot instructions and upload your log.

I tried to post it here and it didn’t work, the file was too big. I also tried pastebin and the file is still too large, it’s 24,979KB

Open citra, launch the game, as soon the graphical issue occurs close citra, open the folder C:\Users\%username%\AppData\Roaming\Citra\log and upload the citra_log.txt again. your log shouldn’t be too big now.

On another note, it seems you don’t know how to find your system specs. I recommend the free utility Speccy for this.

The file is too big even when I close Citra as soon as there is a bug because there are so many errors in the log. Also I figured out how to find out my GPU or whatever and it is an Intel® HD Graphics 520 and someone told me than Intel HD Graphics is not supported in Citra

The only hard requirements for the official version of Citra is a graphics chip that supports at least OpenGL 3.3 and a 64-bit OS running on a standard PC, but you definitely want a processor with the highest possible performance per core.

So you need to figure out if your system can support both of those.