Mario 3D Land hitches

When playing Super Mario 3D Land, my game has random hitches in frames and slightly freezes. This doesn’t happen in any other game except this, so I don’t know whats causing this

System Information

  • Operating System: Windows 10
  • CPU: Intel i7 9700k @ 3.6 GHz
  • GPU: RTX 2060
  • Citra Version (found in title bar): Nightly 1594
  • Game: Super Mario 3D Land
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296citra_log.txt (50.8 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

System Information for Support

Client Version                                Nightly 1594 HEAD-d88d220
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce RTX 2060/PCIe/SSE2
GPU Driver Version                            451.67
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You are using open source system files for Mii data. This will appear as your Mii having broken graphics, but will not affect the stability of the game. In order to resolve this, please refer to our guide on dumping system files. https://citra-emu.org/wiki/dumping-system-archives-and-the-shared-fonts-from-a-3ds-console/

Yeah the emulation isn’t perfect, it’s something you will have to put up with for now. Sorry for the inconvenience. I have for example imperfect frame pacing in Monster Hunter games.

You should do this though to prevent a bug:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

ah, makes sense.
thanks for the response!