Mario and Luigi - Dream Team Bros. mid-game crash


#1

Issue:
During the dialogue sequence with dreamstone spirit.
When he tries to move downstairs suddenly disappears (probably a glitch), FPS drops and afterwards the emulator crashes. Here’s my screens.

System Information

  • Operating System: Windows 10 Home
  • CPU: i3-3240T 2.9GHz
  • GPU: Intel HD Graphics 2500
  • Citra Version : eb8a7a9
  • Game: Mario and Luigi - Dream Team Bros.
  • Screenshot of Issue :

Log: http://pastebin.com/sqpST9ui

If you guys need I have savefiles (ML4.sav) too: https://mega.nz/#F!idFXnBYa!GVdsqFTdN2bFbFXPwbE06A


Dream Team Bros. Crash... Again
Dream Team Bros. Crash... Again
#2

The log is very incomplete. Please fix?


#3

Unfortunately this is all. From load to crash (I saved in the room next to the one with the bug).


#4

[ 0.411157] Audio.DSP audio_core\hle\pipe.cpp:DSP::HLE::PipeWrite:134: Application h

thats where the log cut off. see how it doesn’t make a full sentence. thats how jayfoxrox know the log is incomplete. please follow the guide linked on how to get a full log for citra.


#5

Test re-done (obviously nightly guide), same result. https://pastebin.com/PW2WR6wh

[ 2.143487] Audio.DSP audio_core\hle\pipe.cpp:DSP::HLE::PipeWrite:134: Application h
The line interruption was probably due to the crash that cut the log by writing “Application has stopped working”.


#6

May I ask news about the problem?


#7

Never seen that before. I suggest you dump your shared font, and if it’s still not working, it might be a bug in Citra. These are the guidelines for making an issue:

Report the issue on GitHub after verifying nobody else posted it already.

We usually call our issues: "Game title - Observed problem"
Do not tag your issue name, it will be done for you (We’ll add “A-Audio” tags etc as we see fit, so do not include tags like “[Audio]” in the title)

When submitting the issue, make sure these links will still be reachable in 1-2 years.
Some issues are hard to track down. And even if they are fixed it’s good to have documentation reaching back a couple of months.

Please make sure to mention the latest commit hash/id of the nightly/master build you were using (which should be in the window title).


#8

I’d rather not have an issue about this on GitHub.
The log issue is probably because of buffering issues with the terminal. Our docs / code should be fixed accordingly.

Without the proper log we can’t help anyway.


#9

What do you propose to solve this (if there is any solution according to you)?
Whenever I try the log always stops be writed at the crash.


#10

what is the command you are using to dump the log?


#11

citra-qt 2>log.txt, just like the guide says.


#12

hehe just curious as we edited that post a few days ago. it used to say something different. it was functionally the same command, but a few of us were curious to see if the old command was the cause of the cut off log. apparently thats not the cause though…


#13

I had the same problem until I discovered that Citra was using the integrated GPU. Once I switched it to the dedicated one, it was able to go through this part with no problem.


#14

Where you find that option


#15

I assume you’re referring to switching to the dedicated GPU? If you have a laptop with Nvidia graphics you can open Nvidia control panel. After running a game in Citra once you can add a program>Citra and switch it to use the “high performance Nvidia” graphics


#16

When i wanted to open the control panel it says: You use at the moment none registers who is connected to a GPU of NVIDIA


#17

Still unsolved. Has this bug still not been fixed or given a solution?


#18

I have EXACTLY the same problem…
no one with an idea?


#19

It seems there’s still no issue on GitHub for this, which, as @JayFoxRox said, would be a much better way to track progress.


#20

[Moderator: This message has been moved here from a duplicate topic.]

Hey, it’s me again. While casually playing the game, when it comes time for the Dream Stone spirit to go downwards, the game crashes. The pipe in the beginning in the area also crashes. Did some searching on the issue and found this topic:

When looking through the topic, the only thing that might have resembled a solution to the issue was adding a high performance option to Citra in the NVIDIA graphics control. But I have Intel, which doesn’t have that option (or so I looked). According to the topic, nobody ever made a GitHub issue about it, which is the explanation to why this issue hasn’t been resolved yet.

A screenshot of the issue can be found there.
My Citra version is HEAD-c143a5a
The game is Mario and Luigi - Dream Team
My computer’s stats can be found on my Dolphin profile:
https://forums.dolphin-emu.org/User-thundervolt

The log is right here:
https://pastebin.com/RbFBJWxP

Every time Citra has crashed and I’ve reported it, the mods have told me the log is incomplete. I think this is as a result of Windows telling me that it’s crashed and will shut it down for me. So yes, the log is incomplete (sorta), but there’s nothing I can do about it.

Thanks for helping me with the issue.