Mario and Luigi Dream Team FPS drop in Wakeport

Enter a description of your issue here, in full detail.
Playing dream team, and the game was running well (consistently 28-30fps) aside from the first giant battle until I entered Wakeport, then my fps dropped by 10. Is there any way to get it back up to 30 again?

System Information

  • Operating System: Windows 10
  • CPU: Intel i5-8400
  • GPU: Radeon RX 580 4gb
  • Citra Version (found in title bar): Canary 2165
  • Game: Mario and Luigi: Dream Team Bros.

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (22.1 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                               Canary 2165   HEAD-27431c7
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i5-8400 CPU @ 2.80GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.1
Graphics Renderer                            Radeon RX 580 Series
GPU Driver Version                           22.5.2 30.0.21017.1000
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • Please enable the Vsync option if you are experiencing screen tearing.
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

Go to Emulation > Configure > System and set the CPU Clock Speed back to 100%. You shouldn’t mess with this setting at all if you don’t know what you are doing. Then try your game again.