Mario and Luigi paper jam is slow for almost everything

Issue:
Once I get past the menu of the game everything else is slow the fps drops to 20 then at cutscenes the fps is at a single digit and at fighting it depends on the amount of enemies so if there’s to much the frames drop and so does everything else I just the game to run at 60fps or higher.

System Information

  • Operating System: Windows 10 x64 based pc
  • CPU: amd ryzen 5 3600 6-core processor
  • GPU: radeon rx 5500 xt
  • Citra Version (found in title bar): Citra Nightly 1697
  • Game: mario and luigi paper jam
  • Screenshot of Issue (include the full Citra window including title bar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
<https://community.citra-emu.org/t/how-to-uploadcitra_log.txt.old.txt (8.4 KB) [citra_log.txt|attachment]

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

System Information for Support

Client Version                                Canary 1956 HEAD-7a60d46
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 3600 6-Core Processor              
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon RX 5500 XT
GPU Driver Version                            21.4.1 27.20.21002.112
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

Is there anyway to make it run at least ok

Try turn off Hardware Shader, it can speed things up for AMD cards on Windows.
Make sure you load the game normally and not by save states when you turn it off.

If you want to get ~3x more performance you will need to dual boot Linux (e.g Ubuntu) where there are better OpenGL drivers for Radeon; otherwise you will need an Nvidia card.

Sorry for the inconvenience.

so I tried the thing you said and it worked.

1 Like