Mario Odyssey crashes

If I start Mario Odyssey, it outputs “libpng warning: iCCP: known incorrect sRGB profile” but starts to run fine. But when the white hat wakes up mario in the beginning, it freezes and crashes a few seconds after that with the message “Trace/breakpoint trap (core dumped)”
System:

ArchLinux
CPU: Intel Core i5-4590
GPU: GeForce GTX 1060 6GB
8 GB Ram + 8 GB Swap (htop says its more than enough)
yuzu_log.txt (95.6 KB)

UPDATE: It works if I use the yuzu-mainline-bin AUR package instead of the yuzu-git AUR package.

System Information for Support

Client Version                                yuzu Development Build makepkg-a2eb44db8
Operating System                              Arch Linux
CPU                                           Intel(R) Core(TM) i5-4590 CPU @ 3.30GHz | AVX2 | FMA
Graphics API                                  Vulkan 1.2.142
Graphics Renderer                             GeForce GTX 1060 6GB
GPU Driver Version                            NVIDIA 455.23.4.0
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

How does it run in OpenGL?

It crashes at the same point and it now outputs “QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined” (multiple times)
yuzu_log.txt (74.5 KB)

System Information for Support

Client Version                                yuzu Development Build makepkg-a2eb44db8
Operating System                              Arch Linux
CPU                                           Intel(R) Core(TM) i5-4590 CPU @ 3.30GHz | AVX2 | FMA
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             GeForce GTX 1060 6GB/PCIe/SSE2
GPU Driver Version                            455.23.04
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                yuzu Development Build makepkg-a2eb44db8
Operating System                              Arch Linux
CPU                                           Intel(R) Core(TM) i5-4590 CPU @ 3.30GHz | AVX2 | FMA
Graphics API                                  Vulkan 1.2.142
Graphics Renderer                             GeForce GTX 1060 6GB
GPU Driver Version                            NVIDIA 455.23.4.0
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Wait, did you build Master or Mainline? You need to manually build mainline to avoid stopping emulation in the first bad assert.

I build https://aur.archlinux.org/packages/yuzu-git/
I think that’s the master branch.

You need to build mainline, else the emulation will stop in the first bad assert.
Check this: https://github.com/yuzu-emu/yuzu/wiki/Building-For-Linux