Mario Odyssey OpenGL Crash and Vulkan Crash on iGPU

yuzu_log.txt (334.1 KB)

System Information for Support

Client Version                                yuzu Early Access 1482 HEAD-4d35ad770
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7300U CPU @ 2.60GHz | AVX2 | FMA
RAM                                           7.92 GB
Pagefile / Swap                               9.77 GB
CPU Emulation Accuracy Level                  0
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            27.20.100.9313
Docked Mode                                   [x]
CPU Multicore                                 [x]
Async GPU                                     [x]
Assembly Shaders                              [ ]
Async Shaders                                 [x]
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Try with Vulkan.

If Vulkan is not enough, try in docked mode, at least that section.

In Vulkan the Screen flickers and the game becomes unresponsive. I think that I was already in Docked mode but should I try undocked. Do you know why I am having these problems?

Most likely Intel driver specific issues.

I downgraded my driver from the most recent beta release to the newest stable release. After uninstalling all display drivers. The issues still seemed to occur on both OpenGL and Vulkan. The OpenGL problem has always occurred but the Vulkan one is new. The Vulkan issues did not occur around mainline 530 but now it does. After running vulkaninfo before and after the driver downgrade I can see that my Vulkan version has gone from 1.2.167 to 1.2.162. Online the most stable Vulkan release is 1.2.162 but the most recent pre-release I can find is 1.2.170. This makes me believe the yuzu has implemented some features sometime after mainline 530 that use features from Vulkan after 1.2.162. Let me know what you think and I guess intel just needs to update their drivers. I have attached the log file from the Vulkan version 1.2.162 :
yuzu_log.txt (88.7 KB)

System Information for Support

Client Version                                yuzu Early Access 1482 HEAD-4d35ad770
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7300U CPU @ 2.60GHz | AVX2 | FMA
RAM                                           7.92 GB
Pagefile / Swap                               9.77 GB
CPU Emulation Accuracy Level                  0
Graphics API                                  Vulkan 1.2.162
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            Intel Corporation 100.9168
Docked Mode                                   [x]
CPU Multicore                                 [x]
Async GPU                                     [x]
Assembly Shaders                              [ ]
Async Shaders                                 [x]
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

This is an image of the loading screen with the errors.

Once in game it flickers between these two screens and controls are unresponsive. Although Cappy can be heard moving around at regular speed.

System Information for Support

Client Version                                yuzu Early Access 1482 HEAD-4d35ad770
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7300U CPU @ 2.60GHz | AVX2 | FMA
RAM                                           7.92 GB
Pagefile / Swap                               9.77 GB
CPU Emulation Accuracy Level                  0
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            27.20.100.9313
Docked Mode                                   [x]
CPU Multicore                                 [x]
Async GPU                                     [x]
Assembly Shaders                              [ ]
Async Shaders                                 [x]
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

What do you think the issue is?

It really seems to be a recent regression with the Intel drivers. Asking a developer, I will post if I get more info.

I have updated my intel drivers as now intel has released new drivers for the intel CPU/iGPU. I have the latest version of yuzu and I have also got a new computer with the same specs. I still get the crash at the start of Mario Odyssey when waking up in front of Cappy on OpenGL and the Vulkan screen flickers and unresponsiveness.
yuzu_log.txt (306.9 KB)

System Information for Support

Client Version                                yuzu Early Access 1520 HEAD-2a2e03c2c
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7300U CPU @ 2.60GHz | AVX2 | FMA
RAM                                           7.92 GB
Pagefile / Swap                               9.77 GB
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            27.20.100.9316
Docked Mode                                   [x]
CPU Multicore                                 [x]
Async GPU                                     [x]
Assembly Shaders                              [ ]
Async Shaders                                 [ ]
CPU Accuracy                                  Accurate
GPU Accuracy                                  High

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I Don’t know really how Yuzu works but in the log I see the error occur (The freeze) after a shader is trying to be built in this case shader 167 when running on OpenGL.

Should I look into the log file on Vulkan as well?

Can you try in undocked mode? In OpenGL.

I get the same frozen problem on OpenGL when undocked. The Fps is slightly higher though before it freezes. It was at 30 fps when in docked but when in undocked I got 35 fps. The crash occurs in OpenGL when the camera sees the fog in the cap kingdom. This crash has always been a problem for me and I used Vulkan to get around it but now that Vulkan does not work at all once in gameplay I am stuck and I can’t progress in the game. Here is the log file from the crash on OpenGL undocked:
yuzu_log.txt (87.5 KB)

System Information for Support

Client Version                                yuzu Early Access 1520 HEAD-2a2e03c2c
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7300U CPU @ 2.60GHz | AVX2 | FMA
RAM                                           7.92 GB
Pagefile / Swap                               9.77 GB
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            27.20.100.9316
Docked Mode                                   [ ]
CPU Multicore                                 [x]
Async GPU                                     [x]
Assembly Shaders                              [ ]
Async Shaders                                 [ ]
CPU Accuracy                                  Accurate
GPU Accuracy                                  High

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Seems like we’re still the same with Intel hardware.