Mario Party running at 7 FPS with a good PC

Issue:
I just installed Citra and tried to play Mario Party: The Top 100. My PC is fine with emulating PS2 games, so I thought that 3DS is not a big deal.
However as soon as I started the game I got max 7 fps, even on lowest resolution and with hardware rendering (to be honest my GPU wasn’t being used more than 4%).
I might do something wrong, but I have no idea what would that be.

System Information

  • Operating System: Windows 10 64-bit
  • CPU: Ryzen 5 1600
  • GPU: GTX 1060 3GB
  • Citra Version (found in title bar): Nightly 1708 and Canary 1970
  • Game: Mario Party: The Top 100 (PAL)
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (21.4 KB)

System Information for Support

Client Version                                Canary 1970 HEAD-7ee5bf9
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 1600 Six-Core Processor             | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2
GPU Driver Version                            466.11
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • LLE Audio is designed for debugging purposes. Using this option will slow down your game. Try changing to HLE audio.

Omg, seriously…
One audio setting…

Yup, I changed to HLE and now it’s 30 FPS.

It’s not running in a good speed though, it’s like between a bit too slow, then suddenly a bit too fast, not stable

Give Citra more time for Disk Shader Cache, it might help with that. You can also turn off Audio Stretching if it annoys you.

Other than that it is what it is, don’t expect buttery smooth, perfect frame pacing 24/7. I don’t have that on a Ryzen 9 3900X.