Messed up custom textures in Pokemon Ultra Moon

Issue:
Custom textures in Pokemon Ultra Moon are bugged. Everything was fine until today when I booted up Pokemon Ultra Moon and saw that some of the custom textures are messed up. If I I disable them, everything is ok. I’m using Volya’s HD texture pack.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5 4430 @ 3.00GHz
  • GPU: Intel HD Graphics 4600
  • Citra Version (found in title bar): Citra Canary 1949
  • Game: Pokemon Ultra Moon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (5.0 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Your iGPU is known to have problems with your Accurate Multiplication option, to the point that it can actually cause graphical issues. Please try disabling it first in Emulation>Configuration>Graphics>Advanced Tab. If that doesn’t help then I’m afraid there’s not much we can do. This is Citra support, not texture pack support. Please direct any further questions towards the author of the texture pack.

Nope, that didn’t work. Maybe Accurate Multiplication isn’t the root of a problem. Thanks anyway. :frowning_face:

Can you test if it also happens on nightly?

Ok, I just tested in Nightly 1691 and it doesn’t have any problems with custom textures.Either one of the recent Canary updates broke custom textures or my emulator files were corrupted. I’ll try reinstalling Canary and see if it works.
EDIT: The problem persists after reinstalling.

Ok, so if it happened on Canary but not nightly it’s probably caused by https://github.com/citra-emu/citra/pull/5710. There were some custom texture problems before, but it should have already been fixed on the canary version you tested.
There are also other factors we haven’t considered here, like drivers, as your log was incomplete The log only shows citra being opened, but not any game being booted. Ideally you’d want the log to show gameplay on the affected areas.

Here’s a new log.

citra_log.txt (38.4 KB)

System Information for Support

Client Version                                Canary 1950 HEAD-b2b4fed
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-4430 CPU @ 3.00GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon R9 200 Series
GPU Driver Version                            20.11.1 27.20.12033.2007
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

Ah, it seems I was mistaken. You have a dedicated GPU instead of only an iGPU like I assumed. I believe there is a more recent driver available for your GPU, though I doubt that’ll solve the issue with your texture pack.

I just found out that graphical glitches disappear if I disable Texture Filter. I was playing with xBRZ freescale.

Ah, yea. I totally forgot that can actually cause issues with custom textured. Sorry.

Same issue. Played Mario & Luigi on whatever the version was the latest on February 14 2021 and all was OK. A few days ago started Citra again was asked to update and i did. Tried to play pokemon ultra sun and noticed all the textures are loading wrong, like they are picked at random.
tried another game which i played to completion that i knew it was loading textures properly (paper mario) and same issue … you can even tell it’s Mario.
Tried all the suggestions i could find online. No dice :frowning:

However, tried Citra 1862 which was a version that came with the Ocarina Of Time texture pack and that one works just fine.
Citra 1845 that came with the Majora’s Mask also works perfectly.

so there’s something changed/wrong in version 1695

Can you please check the latest Canary version: Release canary-1953 · citra-emu/citra-canary · GitHub
The author of the update that broke the custom textures for a bit said that he already fixed that issue in a recent update. Make sure to disable any textures filters you have enabled as well before testing.

Ok. Why my Citra won’t automatically update to that version?
Anyway, custom textures are still scrambled even with that version.
I’ll use what i have and it’s working. Thanks

Could you please upload a log file of the latest canary version: How to Upload the Log File
As well as a screenshot showing the scrambled textures?

citra_log.txt (152.7 KB)

It works with no filter, however, in the versions i mentioned above that came with the Zelda textures works with filtered textures too. Maybe something to do with the fact that the zelda ones are self contained and the texture folders are in the same folder as Citra and not in AppData/…

It’s official … the custom texture + any of the texture filters cause the textures to load wrong causing a mess like in the above screenshot … i know one solution would be to not use a filter but i like that filter … so for now i’m using the citra version that came with the OOT texture build.

Any update on this? Has anybody figured out a solution? canary 1956 and the custom texture + texture filtering still jumbles up all the textures