MGS3 3D only running at 20%

Tried playing MGS3 3D but once I hit the menu screen the game speed goes from 100% to 20% and stays there.

ASUS Radeon RX 5700 DUAL EVO OC

Intel Core i7-10700 Processor, Tray

Corsair Vengeance LPX DDR4 3200MHz 16GB

Is it not enough or am I doing something wrong? citra_log.txt (637.9 KB)

System Information for Support

Client Version                                Nightly 1628 HEAD-1c8461f
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-10700 CPU @ 2.90GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon RX 5700
GPU Driver Version                            20.9.2 27.20.12031.1000
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

So basically I have bought a pretty expensive graphics card that can play a lot of games I throw at it on max settings but is not able to run a 3ds emulator? God dammit :confused:

I’m pretty sure your CPU ships with an iGPU. That will probably give you better performance.

Yea, I just checked the compatibility page https://citra-emu.org/game/metal-gear-solid-snake-eater-3d/

‘’Metal Gear Solid: Snake Eater 3D runs great in Citra. Graphically, there are no issues other than minor white lines in codecs with above native resolution. May require decent hardware to obtain near full speed. Enabling Circle Pad Pro will crash the emulator.

AMD graphics card wont achieve full speed. Expect full speed until the pipeline to be completely rewritten or another workaround.‘’

You need to set citra to use your iGPU (Intel® UHD Graphics 630) instead of your dedicated GPU, maybe that will give you the performance you need.

I’ll be honest I don’t really understand what you just said :stuck_out_tongue: how do I do that?

Your CPU, Intel(R) Core(TM) i7-10700 CPU @ 2.90GHz, has it’s own built-in GPU: Intel® UHD Graphics 630. Which has better opengl drivers than your dedicated GPU, AMD Radeon RX 5700. Currently, citra is being run by your dedicated GPU. You need to change it so that your iGPU runs it instead.

As for how to do that…Well, I’ve only ever done so in a laptop with an Nvidia graphics card, using Nvidia Control Panel. AMD should have something similar, but I couldn’t guide you through it. You’d have to google it.

ok thx for the tip. I’ll contact support where I bought it tomorrow and see if they can guide me through it. From what I’ve found I’m a bit scared about messing it up since I saw one video where they needed to actually take out the mother board and turn on a switch before going into the BIOS to get it working.

Hopefully it can be done just via AMD control panel or something but I can’t find that I have a secondary card either in my task manager or in the AMD control panel.

To run your iGPU on a desktop computer you need to unplug all HDMI, DisplayPort, DVI cables that goes into your graphics card and only connect to your motherboard instead. But yeah you will need to make sure you haven’t disabled your iGPU in the BIOS.

The other option is to dual boot Linux (e.g Ubuntu) to get more performance in OpenGL applications with Radeon.

Otherwise you will need to switch to Nvidia.

So switchable is no longer an option because of the new amd software program removing it? And will I have to open it to connect it to my motherboard or should it be on the back?

“Switchable graphics” is only available on laptops.

Just look at the I/O at the back of your computer and directly plug your monitor into the motherboard.

A bit late, but seems I will just have to wait a few years until I have to buy a new graphics card. According to the support team where I bought my PC from it’s not possible. I have also tried to get the iGPU to show up by turning my PC on and off and connecting the cable to each port but it wouldn’t show up.

Just so I know what I should be looking for in the future what Nvidia card is recommended? Cause I have an acer nitro gaming laptop with an Nvidia card that while not being able to run the most graphics-heavy game on ultra is able to play a lot of games on High sometimes Ultra settings. It even can run Dolphin no problem.

This depends completely on your budget. High end cards are always recommended for great gaming performance, though if you’re looking specifically for performance in citra, almost any nvidia GPU from the last 3-4 years will do you nicely. The main thing for citra performance is your CPU. So long as it isn’t being ‘‘bottlenecked’’ by shitty opengl drivers, like the ones AMD provides for their GPUs, you’ll be fine.