MH4U Enabling Hardware shading freezes the game

As title said, when I enable Hardware shading, the game freezes. I can hear the sounds and move on the background though, so the game is still going.
This boosts my framerate up considerably, but does this in quest. In Town however, the game works fine. The game works fine without hardware shading, but at half the framerates (roughly 15 fps, enabing the setting doubled it.)

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™ i5-7300HQ CPU @ 2.50GHz
  • GPU: GeForce GTX 1050
  • Citra Version (found in title bar): 1554
  • Game: Monster Hunter 4 Ultimate

citra_log.txt (2.0 MB)

System Information for Support

Client Version                                Nightly 1554 HEAD-7625306
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7300HQ CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 630
GPU Driver Version                            23.20.16.4849
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Might need to reupload that log… been turning it on and off and reloading the game.

lets try this one, restarted citra, redid the issue i had
citra_log.txt (29.2 KB)

System Information for Support

Client Version                                Nightly 1554 HEAD-7625306
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7300HQ CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 630
GPU Driver Version                            23.20.16.4849
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Do you have a discrete GPU? Usually laptops with HQ CPU model come with one. Check in Device Manager under display adapters if you have one.

Im not really tech savvy, do you mean like nvidia’s panel where you installl updates and stuff?

So you have Nvidia? Good, you will need to go to Nvidia Control Panel then in Manage 3D settings set preferred GPU to Nvidia. While you are there, set Power management mode to Prefer maximum performance. You can access the control panel if you right click on the desktop or on the Nvidia icon in the tray (near the Windows clock).

If you have GeForce Experience installed, turn off Battery Boost as well:

ohmygod, can’t believe it was that simple, jeez. It’s working now! Thank you so much!

1 Like

Hey I’m having the same issues with an Intel graphics. What can I do?

Im having the same problem, i know my pc is slow but i can still play with Pokemon XY,ORAS and USUM but playing Monster Hunter games It freezes but the audio is still working fine. Is it possible for me to fix this problem?
citra_log.txt (68.5 KB)

System Information for Support

Client Version                               Nightly 1757   HEAD-ac98458
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i3-4030U CPU @ 1.90GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) HD Graphics 4400
GPU Driver Version                           20.19.15.4835
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [ ]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

i turn off cheat but its the same…pls help if it possible for me to play MH games
citra_log.txt (41.6 KB)

System Information for Support

Client Version                               Nightly 1757   HEAD-ac98458
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i3-4030U CPU @ 1.90GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) HD Graphics 4400
GPU Driver Version                           20.19.15.4835
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [ ]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics

citra_log.txt (34.5 KB)

System Information for Support

Client Version                               Nightly 1757   HEAD-ac98458
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i3-4030U CPU @ 1.90GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) HD Graphics 4400
GPU Driver Version                           10.18.15.4279
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [ ]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

This driver is out of date. To update, download win64_15.40.5171.zip from Intel® Graphics Driver for Windows* [15.40]
Mirror download: https://downloadmirror.intel.com/30196/a08/win64_15.40.5171.zip

Then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Furthermore, because your iGPU has driver bugs, you’ll need to disable Accurate Multiplication in Emulation>Configuratrion>Graphics>Advanced tab to prevent graphical issues from occurring.