MH4U Secure1 KeyX Missing

Issue:
Citra crashes as soon as I try to load Monster Hunter 4 Ultimate, not even getting past loading the shaders. This only started occurring after I updated my AMD drivers to the latest version today.
I have already tried deleting the OpenGL folder in the shaders folder, running the program as administrator, and disabling the disk shader cache.

System Information

  • Operating System: Windows 10
  • CPU: Ryzen 5 2600
  • GPU: RX 6600
  • Citra Version (found in title bar): 1775
  • Game: Monster Hunter 4 Ultimate
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (29.8 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                               Nightly 1775   HEAD-357025d
Operating System                             Windows 10 (10.0)
CPU                                          AMD Ryzen 5 2600 Six-Core Processor             | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            AMD Radeon RX 6600
GPU Driver Version                           22.7.1.220725
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

Update: I actually figured out the issue! It seems AMD’s latest drivers simply don’t work with Citra at the moment, among other issues.

Please try out the latest Citra Canary build It should work with the new AMD driver now.

It works now! Thank you.