MHGen/XX Freezing Canary (1354)

Issue:
Hi, I finish the MHGen and XX before can’t remember the version of that citra (Canary) and now i download the latest version the Canary 1354 but when i do any quest the game keeps freezing but i still here the sound.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i7 - 7500U 2.70GHz
  • GPU: Intel HD Graphics 620
  • Ram: 12GB
  • Citra Version (found in title bar): 1354
  • Game: MHGen / XX
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (94.8 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1354 HEAD-5008d46
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 620
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Enabling Accurate Multiplication still freezing the game when i do any quest.

Your driver is outdated, update to this newer driver: https://downloadcenter.intel.com/download/28289/Intel-Graphics-Driver-for-Windows-10
then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

There is a newer DCH driver but you will most likely need to update to the previous driver using the links above first in order to use the installer for future updates.
You also need to have the latest Windows updates.

1 Like

Problem is fix… Thank You Very Much

1 Like

Hm, apart of having native resolution it looks like you have 3D feature turned on in the game.

You can turn it off here to increase performance and visual clarity:

1 Like

Thanks for the info :+1:

1 Like

I still have this bug even after installing this driver.

Windows 10
Intel i5-620000 @ 2.30 GHz
Intel HD Graphics 520
8GB RAM
Citra nightly 1594
Game: Pokemon AS/OR

Upload a log please: How to Upload the Log File

(File was too big so I had to upload it external, hope it’ll work)

GPU Driver Version: Build 25.20.100.6373

This driver is outdated, you need to update.

Download and install igfx_win10_100.8336.exe from: https://downloadcenter.intel.com/download/29674/Intel-Graphics-Windows-10-DCH-Drivers?product=88193
direct link: https://downloadmirror.intel.com/29674/a08/igfx_win10_100.8336.exe

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Enable Disk Shader Cache
  5. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

If that doesn’t work then perhaps your rom is corrupted and needs to be redumped. Have at least 4GB free space on your Nintendo 3DS’s SD card:


Thanks @tywald for the help! Looking forward to see how it works

Edit: I can already confirm it solves the issue. There was always a 2-3 second interval when the game stopped, then continued with a frozen screen. Now I get that same 3 second stop but then the game continue running as expected without problems.

1 Like