MHXX closing on its own

Issue:
Enter a description of your issue here, in full detail.

mhxx closes as soon as i load the game,but other roms i had worked just fine

System Information

  • Operating System: Windows 10
  • CPU: AMD A8 7500
  • GPU: AMD Radeon™ R7 Graphics
  • Citra Version (found in title bar):
  • Game: MHXX
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (5.4 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1862 HEAD-64fcc11
Operating System                              Windows 10 (10.0)
CPU                                           AMD A8-7500 Radeon R7, 10 Compute Cores 4C+6G  
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

it didnt work i have tried before

its not exactly a graphical glitch, it just doesnt load when i try, citra closes, but other games like lego games work properly with no hitches

Can you try turning off Hardware Shaders in Emulation>Configuration>Graphics>Advanced Tab? See if that allows you to launch your game. If it does not, then it’s probably a bad dump or a bad update. If you don’t have an update installed, please redump your game using these guides:

Dumping Game Cartridges
Dumping Installed Titles

it worked, thank u very much

its loading in but now its running at 50%, it used to run at 100% smoothly with only a few slowdowns. anyway to fix this?

I wasn’t aware it ran before. Re-enable Hardware Shaders, then follow these steps:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure… then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

          it runs at 50% on loading screens and 20% in hunts, getting this to 70% 30fps is enough to make it playable

Lovely, I’d still like you to try what I sent earlier.

its working properly now

it worked for a while but now its back to 30%