Mhxx constantly dropping FPS in game

Issue:
FPS drops in game and in certain maps of the game, but, in hub or village it’s perfectly fine.

System Information

  • Operating System: Windows 10
  • CPU: Ryzen 5 3500
  • GPU: Rx570
  • Citra Version (found in title bar): Citra Canary 1956
  • Game: Monster Hunter XX
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296citra_log.txt (30.3 KB)

System Information for Support

Client Version                                Canary 1956 HEAD-7a60d46
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 3500 6-Core Processor              
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon RX 570 Series
GPU Driver Version                            21.2.3 27.20.14535.3005
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • Please enable the Vsync option if you are experiencing screen tearing.
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

Make sure to turn off the stereoscopic 3D rendering in the in-game options menu to get some better performance if you haven’t already.

Since you have an AMD GPU, you should also try disabling Hardware Shaders in Emulation>Configuration>Graphics>Advanced Tab. This sometimes improves performance in AMD GPUs. Though it’s a bit hit or miss.