MHXX lag and slow down

#1

Issue:
Every time I fight monsters, the game will start slowing down and the music also slowing down.
It really makes my gaming experience very unpleasant

System Information

  • Operating System: Windows 10 Pro
  • CPU: i7 8700
  • GPU: GTX1070 Ti
  • Citra Version (found in title bar): canary1346
  • Game: MHXX
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

#3

Then the emulator isn’t capable of keeping up. Either you need a better computer, or to wait for citra to see further optimizations to run on lower pc’s.

#4

but seriously??? i thought my i7 8700 with 16gb ram and GTX1070 Ti was good enough

#5

disable 3D on the game options. also disable stereoscopic 3D on citra settings, including setting it to 0%. also reduce the internal resolution a little. micro-stuttering is to be expected.

#6

You even have low fps on like Great Maccao or? It’s expected to have slowdowns during Flash Bombs, monster roars etc. when you upscale the emulator atm. There used to be a hack present in Canary 1041 that “fixed” this slowdown but has been taken out.

You can read the reasoning behind the removal here: https://github.com/citra-emu/citra/pull/4089#issuecomment-437635046

MHXX Astalos/Hellblade Dinovaldo Slowdowns