MHXX stopped working. CICertA file missing

Issue:
Hello. Since a couple of days ago I had a sudden drop of performance in terms of loading speed with MHXX which has now evolved in the game being completely unplayable due to citra crashing on the loading screen. Until a week ago, the game could load in a matter of seconds. I played more than 100 hours with it.

Now I don’t know if it’s because of the latest Citra updates (I used the latest Canary version, but the issue won’t fix itself by switching to Nightly 1601), but all of a sudden it started to slow down tremendously while loading the game (to the point that the mouse cursor didn’t respond) and it could crash my laptop as well. Loading could take up to 20-30 minutes. Now it just closes itself even before it starts to load the shaders.

I tried everything, including:
-switching to the nightly build
-update windows
-update the gpu drivers
-reinstalling the game
but nothin seems to work. The log tells me that “CICertA file missing”, but I can’t seem to find anything online.

Many thanks in advance. regards.

citra_log.txt (6.1 KB)

System Information

  • Operating System: Windows 10 (10.0)
  • CPU: Intel® Core™ i7-4720HQ CPU @ 2.60GHz
  • GPU: Nvidia GTX 960m
  • Citra Version (found in title bar): Nightly 1601 (also tried with the latest canary version)
  • Game: Monster Hunter XX
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1601 HEAD-f72be7a
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-4720HQ CPU @ 2.60GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Hi, try this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Thanks man! I tried before to set accurate multiplication to true but I didn’t remove the opengl folder. Now it works again :smiley:

1 Like