Mid-game Ocarina and Majora Crashes

I’m having trouble with consistent crashing while playing Ocarina of Time 3D and Majora’s Mask 3D. Usually manage to get anywhere from ten to thirty minutes of gameplay before another crash. I’m new to the emulation scene and very sorry if I missed something simple!

System Information

  • Operating System: 64-bit Windows 10
  • CPU: AMD Ryzen 5 2600 Six-Core Processor
  • GPU: Radeon RX 590
  • Citra Version (found in title bar): Citra Nightly 1554
  • Game: Majora’s Mask 3D, Ocarina of Time 3D
  • Screenshot of Issue (include the full Citra window including titlebar): The screen simply freezes at a loading point before crashing. If anyone actually needs a screenshot of that, please let me know.

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (755.0 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1554 HEAD-7625306
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 2600 Six-Core Processor            
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon RX 590 Series
GPU Driver Version                            20.2.2 26.20.15019.19000
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hi, try this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it’s there
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to slowly load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

I’m pretty sure this did the trick. Thank you SO much. Can’t regret the eight hours I already have on Majora, but I’m grateful that I won’t be needing to worry about saving nearly as often.

1 Like