Missing library error on Fedora since the last update


#1

Issue:
After updating Citra Nightly to version 715, the program fails to launch every time. Trying to run it in the terminal shows this error message:

./citra: error while loading shared libraries: libsndio.so.6.1: cannot open shared object file: No such file or directory

System Information

  • Operating System: Fedora 28
  • CPU: Intel® Core™ i5-6500 CPU @ 3.20GHz × 4
  • GPU: GeForce GTX 960
  • Citra Version (found in title bar): Nightly 715

Edit: No log since Citra can’t start in the first place. It’s blank.


#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.


#3

yum install libsndio6.1


#4

That command doesn’t work, it only says no match found.

I tried building the library manually (from here) but Citra still can’t find it. Does libsndio.so.6.1 need to be in a specific directory?


#5

I made a compatibility rpm of sndio for use with Citra on Fedora 28. The rpm installs libsndio.so and creates the libsndio.so.6.1 symlink to /usr/lib64. It works fine for me.

Edit: Since I’m not allowed to link to system files anyone may PM me if you want to try the rpm.


#6

Thank you, but I’ve actually tried reinstalling Citra after seeing your post and the latest version works without issue. So I guess that fix isn’t needed?


#7

It’s not really a fix. It’s just a RPM I made of sndio that isn’t available in fedora’s repository. Glad you got it working though. I updated my Citra from an older release and got the same libsndio library error. I’ll try downloading Citra fresh form their website and see if I still get the error.

Edit: On the fresh install I still get the same libsndio missing error as with the upgrade. Oh well, either way i got it working.