Monitor Flickering While Emulating

MONITOR FLICKERING!

This is an issue I’ve had on and off for awhile but I’m experiencing it now frequently than ever. Almost every time I run an emulation it causes my entire monitor to flicker in fullscreen and windowed mode. If I alt tab or have a windowed application over it the flickering stops. It doesn’t matter what I’m emulating or what’s running on my PC.

  • My drivers are up to date
  • It hurts my eyes please help
  • My frames never drop below 60
  • The issue lessens in some emulations, but remains regardless
  • It doesn’t always happen, it’s very inconsistent. Some days I’ll get flickering, while others I wont have any problems.
  • This issue seems to get worse the longer an emulation is running. It starts off barely noticeable, but within 2-3 hours of playtime it becomes flickering insanity. If I end an emulation while the flickering is happening and open it again, the flickering remains just as bad, but if I restart Citra the flickering returns to a hardly noticeable state again.

I have also posted about this in the Discord server.

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 7 2700X Eight-Core Processor [8 CPUs]
  • GPU: NVIDA Geforce RTX 2070
  • Citra Version: 1413 441.87 ( This issue has occurred in previous versions! )
  • Game: All Emulations
  • Monitor: LG G-Sync 2460 x 1440 144p 32"
  • Screenshot of Issue: The issue is difficult to capture with any camera but if necessary I can attempt to provide a video.

Diagnostic Log
citra_log.txt (34.4 KB)

Edit:
For clarity and elaboration.

System Information for Support

Client Version                                Nightly 1413 HEAD-5d502df
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce RTX 2070/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            441.87
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

System Information for Support

Client Version                                Nightly 1413 HEAD-5d502df
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce RTX 2070/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            441.87
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

System Information for Support

Client Version                                Nightly 1413 HEAD-5d502df
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce RTX 2070/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            441.87
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

Found a solution with the help of V-Kiguchi#7758 in the Discord server.

This issue is caused by NVIDIA G-Sync enabled monitors.
Here is a fix:
Open NVIDIA control panel
Click the Display tab
Set up G-Sync
Uncheck the box to disable G-Sync

I hope this helps others who are having the same problem!

2 Likes