Monster Hunter 4 Ultimate Lagging

Issue:
After I solved my MH4U crashing problem, it seems I have another. The game isn’t crashing but is lagging to the point of being unusable. This is a theme between mh4u and mhgen but let’s just focus on mh4u for now.

System Information

  • Operating System: macOS Big Sur Version 1.11
  • CPU: 2.6 GHz 6-Core Intel Core i7
  • GPU: Intel UHD Graphics 630 1536 MB
  • Citra Version (found in title bar): Canary 1903
  • Game: Monster Hunter 4 Ultimate
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
No logs as the game won’t crash. Unsure what to put here.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

The logs tell us more than simply crash info. It’s still useful to upload a log file so please do.

Hopefully this has something. If I need to reupload anything I would be happy to
citra_log.txt (19.0 KB)

System Information for Support

Client Version                                Canary 1903 HEAD-6385727
Operating System                              macOS 11.1
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             AMD Radeon Pro 555X OpenGL Engine
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [ ]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

Go to Citra>Preferences>Graphics>Advanced Tab and disable Hardware Shaders
I’m uncertain if this will help on MacOS but since it has shown to help on Windows with AMD GPUs, it might be worth a try.
Edit: Also please enable Shader JIT in the same location as Hardware Shaders.

I tried to re-open mh4u and had the same issues as before. Here is the log. Do you want me to disable CPU JIT?
citra_log.txt (19.0 KB)

System Information for Support

Client Version                                Canary 1903 HEAD-6385727
Operating System                              macOS 11.1
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             AMD Radeon Pro 555X OpenGL Engine
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [ ]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

That might have been the same one? Here. citra_log.txt (19.0 KB)

System Information for Support

Client Version                                Canary 1903 HEAD-6385727
Operating System                              macOS 11.1
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             AMD Radeon Pro 555X OpenGL Engine
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [ ]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

Sorry, I edited my previous post. You needed to enable the Shader JIT, leave the CPU JIT on.
However, you seemed to have also disabled Hardware Renderer for some reason? You want to leave that one on.
After you have Hardware Renderer, CPU JIT and Shader JIT enabled, test out your game and see if turning Hardware Shaders on or off makes a performance difference.

Thank you, the framerate is so much better! Here is the crash log without hardware shaders. citra_log.txt (24.5 KB)
Here is the crash log with hardware shaders.
citra_log.txt (28.5 KB)
I crashed when I tried to press ‘Continue’ but I’m glad the framerate has gotten better. It seems that I can either play with 2fps or stay stuck at character creation with 40fps. :joy:

System Information for Support

Client Version                                Canary 1903 HEAD-6385727
Operating System                              macOS 11.1
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             AMD Radeon Pro 555X OpenGL Engine
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

Try putting the CPU Clock Speed back to 100%. I know it might be slower, but I want to confirm if it is causing the crash as it is currently at 45%, which could definitely cause crashing.

It seems like it still crashes with 100% CPU Clock Speed.
citra_log.txt (24.5 KB)

System Information for Support

Client Version                                Canary 1903 HEAD-6385727
Operating System                              macOS 11.1
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             AMD Radeon Pro 555X OpenGL Engine
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

MacOS didn’t seem to like some of the recent changes made to Citra. However, this usually causes other users to not launch Citra in the first place. We can rule it out however just to be sure by using an older Citra version and seeing if you still crash:

Download citra-osx-20200707-bd7ee8c.tar.gz (direct link) from https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1587
Extract it and then launch the citra-qt executable inside the extracted folder.

MH4U seems to be running well on the older version you gave me. The game didn’t crash, but here is the log.
citra_log.txt (23.8 KB)

System Information for Support

Client Version                                Nightly 1587 HEAD-bd7ee8c
Operating System                              macOS 10.16
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             AMD Radeon Pro 555X OpenGL Engine
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Great. Hopfully we can keep it that way xD

Also make sure to activate Accurate Multiplication in Citra>Preferences>Graphics>Advanced Tab to prevent a crashing bug from appearing later on that happens when the Disk Shader Cache is enabled when Accurate Multiplication isn’t. So if Accurate Multiplication causes any issues in the future and you choose to disable it, remember to also disable the Disk Shader Cache.

1 Like