Monster Hunter 4 Ultimate red screen

Hi there. Recently I decided to try out and see if I can run this game. Once I loaded up the game its red. Not a red screen but the game itself is red. When I go to character selection on the other hand everything goes black except the character. The video intro of the game seems fine but with some audio issues.

System Information

  • Operating System: Windows 8.1 Enterprise 64-bit (6.3, Build 9600)
  • CPU: Intel® Core™ i7-3630QM CPU @ 2.40GHz (8 CPUs), ~2.4GHz
  • GPU: Intel® HD Graphics 4000
  • Citra Version: Nightly 1564
  • Game: Monster Hunter 4 Ultimate
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (28.5 KB)

Looks like you actually have GT 630M

Sure do.

Ok, update the drivers: you might need to pick clean install under custom/advanced install

1 Like

Where exactly? I had to install the link you placed
Edit: I re-did the whole installation and went to custom/advanced. My bad.
Update: No more red game although there are times when the screens delay duplicate from time to time and it would tend to black screen but I can still hear the game and move around from the main menu.

Upload a new log please.

citra_log.txt (50.9 KB)

System Information for Support

Client Version                                Nightly 1564 HEAD-16913fe
Operating System                              Windows 8.1 (6.3)
CPU                                                 Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                  
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

Ah yeah, now you have to go to Nvidia Control Panel and in Manage 3D Settings, set preferred GPU to Nvidia. While you are there, set Power management mode to Prefer maximum performance

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it’s there
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to slowly load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

1 Like

Where do I get this Nvidia Control Panel? The one that installed is GeForce Experience and there was no Manage tab or Manage category in settings

Right click on the desktop, or on the Nvidia icon near the Windows clock.

1 Like

Well it seemed to work and I was able to get through character selection. All that’s left is the game’s fps.

Are you using the codes to boost performance?

See this:

1 Like

Yeah, the codes are activated. Although I’ll make sure first that I got the update 1.1

Yeah the codes won’t work without v1.1

1 Like

Sorry about this but how do I install the 1.1 update?

Follow the guide below:

1 Like