Monster Hunter 4 Ultimate runs very slow

Issue:
Hello good people! I’ve been having so much fun lately playing Pokemon Y (which runs really well, very minor glitches but absolutely enjoyable) so I decided to try another game I played for hundreds of hours on 3ds, Monster Hunter Ultimate 4. This one though runs really bad, the problem is that the frame is over 40 (not the fps, that is fine, mostly around 30 fps) which results in animation being really slow. During character creation everything was smooth but as soon as the “gameplay part” started, the game started running so slow.

System Information

  • Operating System: Windows 10 64 bit
  • CPU: Intel® Core™ i5-3230M CPU @ 2.60GHz
  • GPU: Intel® HD Graphics 4000 (Radeon HD 8670M is the dedicated one but I run Citra on the intel gpu)
  • RAM: 6 Gb
  • Citra Version (found in title bar): Nightly 1210
  • Game: Monster Hunter Ultimate 4 EUR
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (1.2 MB)

System Information for Support

Enable CPU JIT                                [x]
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
Enable Vsync                                  [ ]
LLE Audio Emulation Enabled                   [ ]
Use GDB Stub                                  [ ]
System Region                                 -1
OpenGL Version                                3.3.0
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 4000

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended for accurate emulation.

Take a look at the MH4 compatibility page for more info. try using your dedicated GPU for better performance.

1 Like

First thing, thanks for the reply. Unfortunately playing on my dedicated GPU sin’t an option since performance gets much worse (frame from 40 rises to around 150 which means animations get even slower). Tried the suggestion on the game compatibility page and noticed a slight improvement, from 40 frame I got 35 but stil bad since over 16.67.

MH4U is a very demanding game.

I can barely reach 60fps with i7-3770K overclocked to 4.3GHz with GTX 1070.

Hiding the HUD & Map while in quests(see options menu in game) and make the bottom screen empty(you can leave target camera only if you want) might net you a few more frames. The HUD can still show up when you hold L.

1 Like

Yeah, looking at the feedbacks of the compatibility page I guessed so. The funny thing though is that Generations, which came out after 4U and shares the same engine, runs waaay better (I’d give it 8.5/10). From what I can understand, reading both compatibility pages, the problem with 4U is that 3D can’t be deactivated and that is the very reason why it’s so demanding :confused:

I fixed my problem, so I thought I’d share… though it’s probably late now. I went with “Auto (Window Size)” on the Internal Resolution, checked “Accurate Multiplication”, and lastly underclocked (!) the CPU Clock Speed to 35%.

It’s not perfect, but there is virtually no slowdown.