Monster Hunter Generation Stucks at Loading Screen

Issue:
So, I just test out Monster Hunter Generation and it seems to work well. After the character creation and started the game, it stucks at the loading screen and the emulator is not responding (can’t adjust screen layout, etc.) but I can still hear the sound pretty well and the game is still ongoing (can click the conversation of the NPCs) but I cannot see what’s going on. I already updated my drivers and my OpenGL version is 4.3. I also enabled the Hardware renderer, tried different settings and it’s still not working.

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™ i5-4210U CPU @ 1.70GHz ~ 2.40GHz
  • GPU: AMD Radeon R5 M330
  • Citra Version (found in title bar): Citra Canary #754
  • Game: Monster Hunter Generation

Diagnostic Log
citra_log.txt (155.7 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

citra is using the intel integrated GPU, to use your amd gpu follow these steps
the most important part is to add citra here and change to high performance.
upload your log again if the issue persists.

note: the intel integrated gpu may work better in other games. if you wish you can always try both to see which is better for ‘X’ game.

1 Like

Could this be shader compilation stuttering? Try waiting it out. The game is still running according to the FPS.

I did wait it out for like 10 minutes or more but nothing happened. :frowning:

Thanks mister! It does works this time but the in-game is slower than I expected. It runs at ~50% speed with ~15 FPS. I did optimize my settings (did the advance settings to adjust the best performance, highest performance on power options, enabled 4 processors). On the other games like Pokemon Omega Ruby, it works perfectly fine though.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

if you are using the amd gpu you can enable ‘Enable Hardware Shader’ on some games like monster hunter and pokemon without problems (usually).

I did use the AMD GPU and enabled the ‘Hardware Shader’. I just check in taskbar to make sure I used the AMD GPU. I guess the problem is my graphics card (maybe it’s outdated or not enough power to take higher GPU) or my RAM.