Monster Hunter Generations gets stuck at first loading screen?

Monster Hunter Generations get stuck at loading screen:
Every time I load up Monster Hunter Generations, the game gets stuck at the loading screen after character creation. I did find another topic which talked about this freeze and had the same cpu but had another gpu which i do not. Also the cutscene does not load but the sound is heard from the cutscene

System Information

  • Windows 10
  • Intel I5-4210U
  • Intel HD 4400
  • Citra Nightly 1628
  • Monster Hunter Generations
  • Heres The pic

Log:-
citra_log.txt (24.4 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

System Information for Support

Client Version                                Nightly 1628 HEAD-1c8461f
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4400
GPU Driver Version                            20.19.15.4380
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

nah it didnt work the game still freezes at that exact moment
Even tried updating all the drivers and visual c++, didnt work

Upload a new log please, so we can check if the drivers are updated.

i had updated it before posting it here because i saw someone else with the exact problem with the same cpu, i tried whatever the post said and still it didnt work

Ok, but 4380 is an outdated driver. Do these steps to make sure you have the latest:

Download win64_15.40.46.5144.zip from https://downloadcenter.intel.com/download/29804/Intel-Graphics-Driver-for-Windows-15-40-?product=81016
direct link: https://downloadmirror.intel.com/29804/a08/win64_15.40.46.5144.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Since Intel HD 4400 is a problematic iGPU, you might need to also turn off Hardware Shader.

You might need to even use a very old Nightly version which still had the “AMD hack”: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-860
If it works, try https://github.com/citra-emu/citra-nightly/releases/tag/nightly-861 and see if you get the problem again then you will know for sure.

You want the latest drivers regardless, 4380 is from 2016.

oh yeah i forgot, my igpu driver is modded because i wanted to play destiny 2 with acceptable framerates which did happen so i let it be. Now i have updated it tho

the cutscene loads but the game runs very slow now after turning off hardware shader

it runs at 21% now after turning off hardware shader

Nightly 860 works tho, thanks