Monster Hunter Generations screen glitch/crash but there is sound after a couple of minutes

Issue:
After the start menu, everything is normal but after a couple of minutes the screen freezes and glitches, but the sound is stil there (citra working fine after that, citra isnt crashing)

System Information

  • Operating System: Windows
  • CPU: Intel HD 530
  • GPU: I5-6500 3.20GHz
  • Citra Version (found in title bar): Citra Nightly 1762
  • Game: Monster Hunter Generations
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (32.5 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                               Nightly 1762   HEAD-1382035
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) HD Graphics 530
GPU Driver Version                           30.0.101.1660
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [ ]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • Please enable the Vsync option if you are experiencing screen tearing.
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

Already tried enabling Accurate Multiplication, makes the game bit laggier but still crashes

After playing again for a while, it seems it only crashes when meeting the npc meowstress, but i really need this npc for progression

Please go to Emulation>Configuration>General and select Reset All Settings. Now start your game and see if you run into the same issues. If you do, upload another log file.