Monster hunter xx astalos

#1

Issue:
Enter a description of your issue here, in full detail.
I can set my resolution to max and run the game just fine but when astalos is on the same screen it slows down and becomes unplayable

System Information

  • Operating System: windows 10
  • CPU: intel i3
  • GPU:geforce gtx 1060
  • Citra Version (found in title bar): citra canary 654
  • Game: monster hunter xx
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (380.6 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#2

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#3

This is due to texture cache misses, the same problem you get during monster roars and flash/sonic bombs. To mitigate it, run at 240p(native resolution). See if that helps.

#4

Thats it? So no real solution for this? Everytime i got astalos quest i need to set it to the shittiest resolution?

#5

Yes. There was a hack called “Ignore Format Reinterpretation” in an older texture cache version (https://github.com/citra-emu/citra/pull/3281/commits/34ff77f5f75c4532406a3e140f037ddc098174ad ) which allowed texture cache misses to be ignored and that helped but it broke other games like Paper Mario so it was taken out.

I think the next step would be to implement hardware texture decoding/encoding iirc. There is no ETA for that though.

#6

Is citra addressing this problems through future builds? If that’s the case ill wait till mhxx run perfectly in citra. Thanks for the replies

#7

And btw is there a fix to this one ?

Render.OpenGL video_core/renderer_opengl/gl_shader_gen.cpp:SampleTexture:221: Using Texture3 without enabling it*

#8

Don’t sorry about this. It is probably a harmless warning. Do you notice graphical inaccuracies?

#9

No graphical glitches or anything but i assumed this is the reason why my game is too slow. I disabled 3d on mhxx but it doesn’t help at all. Any recent build i try works just fine but i need this specific build because it solves my problem with astalos making the game super slow. I dont want to turn the resolution to lowest setting every time i have a quest on astalos. Found a video on youtube where he shows this build from dec 2017 works fine with the game and it doesnt slow when you hunt astalos.