Monster Hunter XX Frame Drops

Issue:
Not roar or flash-bomb related. Game randomly spikes from 60fps down to 30-35fps for about 5 seconds every 5-10 minutes. Doesn’t seem to be related to any specific graphical event- happens even when standing idle in town. Also experienced by others playing the same game on NVIDIA hardware, so the issue is likely not tied to my graphics card or CPU.

System Information

  • Operating System: Windows 10
  • CPU: Intel i5-2500k
  • GPU: NVIDIA GTX 760
  • Citra Version (found in title bar): Canary 1404
  • Game: Monster Hunter XX
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (37.4 KB)

System Information for Support

OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 760/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [ ]
System Region                                 [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

System Information for Support

Client Version                                Canary 1404 HEAD-68056af
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 760/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [ ]
System Region                                 [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

System Information for Support

Client Version                                Canary 1404 HEAD-68056af
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 760/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [ ]
System Region                                 [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Enable ‘Enable Shader JIT’. did you set the ‘3D Feature’ to off on MHXX settings? also reduce the internal resolution.

This might help you a bit.

Yes, I have tested with ‘Enable Shader JIT’ both on and off, as well as experimented with the internal resolution- the frame spike still occur on native resolution. Yes, the ‘3D Feature’ is off in the MHXX settings.

Not sure if your response is serious but:

  1. The issue still occurs for others on far better hardware than mine, so it’s unlikely to be related to my hardware.
  2. I have the latest version of Citra- have also tested on previous versions as well as unofficial builds.
  3. Issue still occurs on native resolution.
  4. The game is taking advantage of my GPU without issue- the framerate is consistently 60fps (with framerate unlocked- 30fps without) 90% of time bar the frame spikes I am describing.

Thank you for your generous input regardless.

Some stutter or framerate spikes should be expected when new effects appear on screen but it shouldn’t be too constant.

Again, the frame spikes occur regardless of game activity and don’t seem to be tied to any special effects or entities spawning. They occur even if standing stationary in town, like clockwork every 5-10 minutes, and are a massive 20-30fps drop that lasts about 3 seconds, as opposed to the 3-5 fps drop that special effects may cause.

Open window’s power options and set it to “High Performance”. also to check if citra is causing such problems, play again until this issue occurs and upload your log.

I have tried using both the High Performance and Ultimate Performance Windows 10 power plans, but the issue persists. I have also tried tweaking the relevant settings in the NVIDIA control panel to ensure that the Citra is seeing optimal performance from my PC, but the issue persists.

I do not believe the issue is hardware or performance related, since the emulator runs flawlessly 90% of the time until the framerate spikes.

It’s most likely related to this issue:

Pretty severe the first 7 seconds, goes away at 21s-24s then it happens again and ends at 34s.

This was before the 60fps code but the game does this weird drop without it but here it still says 30fps.

It may indeed be related- the duration of the issue seems similar to the frame spike I’m experiencing, but in my experience the game doesn’t completely freeze, it just chugs at a low framerate for a few seconds.

When using the 60fps cheat, the framerate drops to 30-40fps, and when not using it (playing at 30fps), the game drops to ~10fps, which again leads me to believe that the issue is not due to my hardware not being powerful enough to run the emulator, but is instead some sort of rendering issue.

EDIT: Apologies, looks like the freezing was a video playback error on my end. Watched your video again and the “frame skipping” is very similar to what I’m experiencing. Let me know if you get any leads on a solution!

With the 60fps code instead of “frame skipping” it would produce severe jittering effect, it’s like the screen is shaking. I don’t have a new recording of it(maybe I should).

Haven’t had the “screen shaking” effect, but when the issue occurs in both 30fps and 60fps mode, my Citra FPS counter will visibly plummet.

Here is a video clip of the issue, recorded after running around in circles for a few minutes. The stutters at the very beginning and end seem to be an issue in the recording, as they did not occur in game, but keep an eye on the FPS counter near the end of the clip.

Attached is my citra log from the same play session.


citra_log.txt (54.3 KB)

System Information for Support

Client Version                                Canary 1404 HEAD-68056af
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 760/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [ ]
System Region                                 [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

It’s like this for me with the code:

[[Better Render Settings]]

citra_enabled

60D4BF48 00000000

B0D4BF48 00000000

00006B20 089F036A

D2000000 00000000

this cheat gives you a huge fps boost. Im also running it on canary 1041 which has less framedrops.