Monster Hunter XX graphical glitch

In some areas there is this odd flickering and it pretty much looks like static on a tv screen. On an unofficial build I used, the graphical glitch was not present and I had decent performance but latest Canary is much better in performance (especially around multiple monsters and hit effects). When turning 3d on via in-game options, the graphical issue is gone at the cost of performance (literally 50%). Nightly doesn’t have this issue but also performs about half as well as Canary does.

System Information

  • Operating System: Windows 7 Home Premium 64-bit
  • CPU: i7-7700K
  • GPU: GTX 980
  • Citra Version (found in title bar): Citra Canary | HEAD-2ca5e92
  • Game: Monster Hunter XX
  • Screenshot of Issue (include the full Citra window including titlebar):

Log: Does it apply for this issue?

This issue is known and it affects Nvidia cards only. (Maxwell and Pascal cards, specifically).

There is no way of fixing this, and only certain scaled resolutions are affected.

Hey, there is currently a solution for this problem. You have to disable tiled rendering from the nvidia profile inspector.

Instructions Here

Only difference is that you have to create a new profile in nvidia profile inspector and add the application “citra-qt.exe” to it.

1 Like

Hi, i am also getting this blocky artifacts but only on recent updates. I can confirm that i have one build (which I still use now until there are new builds without this problem). I also test on many resolution or scaling and I didn’t encounter any of this bug, I hope it could help you guys to fix this bug,

Build that I use: Citra Canary | HEAD-56e361b

Recent Build: Citra Canary | HEAD c29ae76

1 Like

You are totally Right man i have the same issue with the last nightly version 787, well runs better full speed even in 10X but with graphical glitches, mean while in the version 56e361b there isnt graphical glitches but dont run so well, there is anoter solution for this issue?

me an my friend found a way to fix this but its a bit strange and needs the help of astalos, set your res to native x3 the go to astalos an set it to native x 1 and bam fixed… dunno how the fu.k this even works lul

We have a fix for this in latest canary builds. Soon it won’t need any workarounds. (Once it gets merged)