Monster Hunter XX loud noise glitch

When playing Monster Hunter XX (patched into English) I get this glitch where a jumbled noise (like running water but distorted) occasionally plays really loudly. So far I have only encountered it while fighting the Arzuros enemy, while it is panting. It happens with all sound engines equally. I would greatly appreciate if someone could look into this and fix it

System Information

  • Operating System: Windows 10
  • CPU: Intel(R) Core™ i5-1035G1 CPU @ 1.00GHz 1.19 GHz
  • GPU: Intel(R) UHD Graphics
  • Citra Version: Nightly 1774
  • Game: Monster Hunter XX (JP)

citra_log2.txt (197.5 KB)

System Information for Support

Client Version                               Nightly 1774   HEAD-2d95b99
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i5-1035G1 CPU @ 1.00GHz | AVX512 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) UHD Graphics
GPU Driver Version                           27.20.100.8280
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

These are known issues. You need to wait for emulator improvements.