Monster Hunter XX makes Citra crash upon entering a quest

Hi, I’m completely new to this site so I’m sorry in advance if I fail to follow the protocol for questions like these.
For a little background, I’ve used Citra to run Monster Hunter 4 before and it was working fine (except for some graphic glitches that didn´t bother me too much). So I installed XX, an update to the game and a patch for Spanish translation (two of my friends installed these same three files and the game worked for them).
However, when I wanted to do a quest with them online, the game froze and the emulator closed the second I entered the quest, no error popup or message, I tried again with an offline solo quest, same result.
I’ve tried reinstalling the game, reinstalling the emulator, updating Nvidia drivers, turning on Accurate Multiplication, lowering the quality of the graphics, couldn’t figure out how to delete the save file so didn´t do that. Thing is, I don´t know what else to try so I would really appreciate some help.
English isn´t my first language so I’m sorry if there are any mistakes on this.
Thanks in advance for any help
(Screenshot is from the second the game froze)

System Information

  • Operating System: Windows 10 Home Single Language, Version 22H2
  • CPU: Intel(R) Core™ i5-10300H CPU @ 2.50GHz 2.50 GHz
  • GPU: Intel(R) UHD Graphics, NVIDIA GeForce GTX 1650 Ti
  • Citra Version (found in title bar): Citra Nightly 1985
  • Game: Monster Hunter XX
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (21.7 KB)

In order to save a copy of the log, follow this guide:

System Information for Support

Client Version                               Nightly 1985  HEAD-e2d8eef
Operating System                             Windows 10 Version 22H2 (Build 19045.3324)
CPU                                          Intel(R) Core(TM) i5-10300H CPU @ 2.50GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            NVIDIA GeForce GTX 1650 Ti/PCIe/SSE2
GPU Driver Version                           537.13
CPU JIT                                      [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

Ended up just doing a complete wipe of the emulator (uninstalling it) and erasing all the related Citra folders in %appdata% and %localappdata%. It seems to work now.