Monster hunter xx multiplayer problems

Issue:

I’m having trouble playing monster hunter xx with 3 or more friends, whenever I try to connect to the hub, the message “unable to connect the hub” appears and increases one person in the room until the room disappears from the connection options in the game. I changed the console id already tried to use nighly but the error continues I can only play with a room with 2 people counting on me if another tries to log in gives this error to my friends too

System Information

  • Operating System: Windows 10
  • CPU: intel core i5-6200U
  • GPU: 2.4 Ghz
  • Citra Version (found in title bar): 730
  • Game: Monster hunter xx
  • Screenshot of Issue (include the full Citra window including titlebar):
    https://ibb.co/hrgo8z

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (452.1 KB)

I found some issues in that log that need resolving:

still not working with me and my friends

What about your friends? They have to check as well. There is another bug where when the hub gets full and someone leaves it thinks the hub is still full when it’s not so you have to remake it. Annoying but there is no fix for it yet.

we change console id, and try anothers servers or create a new hub but always 2 enter in the hub and the third can’t

Then I don’t know :confused: all I can say is to double check everything, you can ask your friends to take screenshots of their Citra settings so we can all see here. Include your own settings as well.

I and my friends continue to try but the error continues to only be able to connect two by hub the third one always receives the same message “unable to connect the hub”, but I saw that in the site it talks about the canary to work with up to 4 players however which are the monster hunters running? We are playing XX

I’m not really sure what the issue is, it might not be a configuration problem. Can you make an issue?

I can only play in a hub with another friend the third is always out, the hub is only accepting 2 players at a time, but I tried a version 2 months ago and it worked, however it is very slow the version does not run with so many fps

An issue has been posted about it: https://github.com/citra-emu/citra/issues/4090

Where can I download the version that works from citra or valentine?

I will wait for the new versions and hope that works thanks for the attention you are to be congratulated