Motion controls stop working after restarting Citra

Issue:
I’m using my Nintendo Switch Pro Controller with Betterjoyforcemu. The motion controls worked instantly when I first tried it. When I opened up Betterjoy and Citra again, it didn’t work at first but with a bit of messing around I got it to work (I restarted Citra a couple of times and plugged and unplugged my controller). If I close Citra, it takes between 10 minutes to one hour to get the gyro working. Citra instantly recognizes all the other buttons it’s only the gyro that doesn’t work when I start Citra. When the gyro does work, it keeps working until I close Citra.

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 7 3700X 8-core Processor
  • GPU: NVIDIA GeForce RTX 2060
  • Citra Version (found in title bar): Citra Nightly 1706
  • Game: The Legend of Zelda: Majora’s Mask 3D
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

citra_log.txt (43.9 KB)

System Information for Support

Client Version                                Nightly 1706 HEAD-6e16081
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 7 3700X 8-Core Processor              | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             NVIDIA GeForce RTX 2060/PCIe/SSE2
GPU Driver Version                            466.27
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.