Motion/Touch configuration intermitently failing

Even though my Motion/Touch configuration is set properly, assigned to d-pad up/down and R/L shoulder buttons, it sometimes fail when I press them or even if I try to click the bottom screen directly. What is strange is that it works fine for a while (sometimes a couple of minutes) then it stops responding, usually when I go from one “scenario” to another. I found out that when the issue happens, if I open config menu and just hit OK without making any changes, with the game still open, it will go back working but eventually they stop again. I’m using an Xbox Series X wireless controller.

System Information

  • Operating System: Windows 10 Pro 64-bit
  • CPU: Intel Core i7 6700K @ 4.00GHz Skylake 14nm Technology
  • GPU: 4095MB NVIDIA GeForce RTX 2060 SUPER
  • Citra Version (found in title bar): Citra Nightly 1887 (the issue was still occurring with a couple of previous nightly builds though)
  • Game: Ocarina of Time 3D
  • Screenshot of Issue (include the full Citra window including titlebar):

In this gif you can have an idea of the issue. When I reach Hyrule Fields, it works at first and then it suddenly stops. You can see me trying to press the buttons and click the bottom screen, but it does not work.

Diagnostic Log
citra_log.txt (16.7 KB)

Unfortunately your log file seems to be incomplete. Please reupload a new one using the steps below.

  1. Open Citra and go to File → Open Citra Folder

  2. Play the game until you find the issue.

  3. Close Citra to get the log file (Do NOT restart Citra, as it will wipe the file )

  4. Upload the new file to the support ticket

Hello Jaffa,

I have updated the log and gif files.


Please try this older Citra Nightly builds:

Download citra-windows-mingw-20230326-9ef4204.7z from Release nightly-1866 · citra-emu/citra-nightly · GitHub
Extract it using winrar or 7zip, then launch the citra-qt(.exe) found inside of the extracted folder. Then try and see if you can reproduce the issue.

Same behavior.

Log file:
citra_log.txt (18.9 KB)

Just an update: I noticed that if I cycle through window modes using f10 it also fixes the issue temporarily. So that’s what I’ve been doing, when it stops working, I change the window mode to fix it until it breaks again and so on.

Found a possible workaround for this one. While playing Majora’s Mask, I noticed that the touch icon would remain pressed even after lifting the shoulder/trigger button up, as if I was still “touching” the icon on the screen.

So I tried the following and it worked:
1 - Changed both R and L trigger buttons mapping to “not set”;
2 - Remapped both in Motion/Touch config and made sure that I pressed them very quickly (without holding it down) when doing so.

So far, the issue did not happen again. Do you want me to keep this bug open so it can be further looked into or would you rather have this workaround marked as a solution?

Ah, I see what happened here. When mapping the trigger buttons, hold them down before selecting to map them. Once a button is map-able, release the trigger. That way it’ll get mapped in reverse, which should fix the issue.

1 Like