Mouse not registering clicks in the right spot

Playing tomodachi life and i have to click a bit above the buttons and i dont know how to fix it? The citra app itself is fine but in-game its detecting me clicking below where im actually trying to click and it’s annoying me. Only been an issue since the most recent update

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

Having this problem with Tomodachi Life too! Hitching onto this thread to upload my log, hopefully it helps. Issue as described by OP. I have to click a bit above items I want to click on instead of directly in the middle / anywhere on the button itself to select it correctly. I waited a few days to install new Citra updates in hopes that the issue would be gone but it’s still persisting. This is the log from Citra Nightly.

citra_log.txt (389.2 KB)

Please update to the latest Citra Nightly build. If the same issue persists, upload a new log file.

We need more information to help you. Please reply with this template completely filled out:

System Information:

  • Operating System:
  • CPU:
  • GPU:
  • Citra Version (found in title bar):
  • Game:
  • Screenshot of Issue (include the full Citra window including titlebar):
  • Upload the citra_log.txt file from this thread by dragging and dropping it here as a file attachment.

Screenshot attached: Added an arrow to where my mouse was pointing – slightly above any item selection to register a click on whatever I actually intended to click on. Screenshot doesn’t capture my mouse cursor so I had to add the marks manually.

New log file uploaded:
citra_log.txt (217.2 KB)

Let’s try wiping the old config file. Go to File>Open Citra Folder and delete the config folder found here. Now try your game again.

I tried, the issue is still the same. Tried on the latest canary build too. Same thing. I’ve been playing this on and off for a year or two on Citra and never had this issue until recent updates - There was quite a lot of updates pending at the time since I haven’t opened Citra for a month or two I think.

I have the same issue since Nightly 1867/1868, at the same Build Citra also started to crash when loading Savestates (this seems to have been fixed). Using a separate window for the touchscreen fixes the issue but I would prefer to use one window.
Also Nightly 1866 seems to work fine, so I am using that version for now.

1 Like

Yep, on Nightly 1874 and the input works fine when using ‘Separate Windows’ screen layout.

One of our devs was able to reproduce this. Hopefully we can get a fix out soon.


Awesome, thank you for the update!

sorry for not posting a log or anything i didnt know how to and was busy, the issue has gone away but only after the game would crash on startup (i found the solution in another post, deleted the shaders file and it was fixed), after doing that the mouse has been clicking correctly

Corrupted shaders then maybe? @Nicki_Sim please try also doing this. Go to File>Open Citra Folder, then delete the shaders folder found here. Now try your game again and see if the touch issue remains.

Updated to nightly 1877 and tried both deleting config, deleting shaders, and deleting both together (3 separate instances) and all did not work. But I went to config > reset all settings and the clicks are back to normal now. Hopefully that works for others who are having this issue too!