Mouse not working when using custom layout

Perhaps this has already been addressed or solved but when playing with a custom layout I’m unable to use the mouse to interact with the bottom screen. It works with layouts that aren’t custom so I’m guessing this has something to do with how I set up the custom layout in the ini file?

Post what nightly you used, your custom layout settings, monitor resolution and game tested. Someone here might be able to replicate it.

415d3c0, monitor resolution is 1080p. I’ve used multiple games Majora’s Mask, Pokemon Moon, Omega Ruby. Mind you most of these layout numbers were forced, I really have no experience so this is most likely where the problem is arising.

[Layout]
layout_option=2
swap_screen=false
custom_layout=true
custom_top_left=0
custom_top_top=105
custom_top_right=1350
custom_top_bottom=940
custom_bottom_left=1355
custom_bottom_top=300
custom_bottom_right=790
custom_bottom_bottom=700

Sorry this is a bit late. You’ve probably already figured it out by now. But just in case you haven’t, I think I figured out your problem. I think it’s your setting for custom_bottom_right… it’s actually less than custom_bottom_left. I’m actually surprised it displays the screen. Try setting custom_bottom_right to a higher number (like 1920) and see what happens.

I’ve been using a custom layout with mouse without problems. Here is mine (which is actually surprisingly similar to yours, but the bottom screen is on the left):
[Layout]
layout_option=2
swap_screen=false
custom_layout=true
custom_top_left=480
custom_top_top=108
custom_top_right=1920
custom_top_bottom=972
custom_bottom_left=0
custom_bottom_top=360
custom_bottom_right=480
custom_bottom_bottom=720

Here’s another one I have with the bottom screen on the right:
[Layout]
layout_option=2
swap_screen=false
custom_layout=true
custom_top_left=0
custom_top_top=108
custom_top_right=1440
custom_top_bottom=972
custom_bottom_left=1440
custom_bottom_top=360
custom_bottom_right=1920
custom_bottom_bottom=720

2 Likes